aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-12-13 16:07:27 +0000
committerSteve Wills <swills@FreeBSD.org>2015-12-13 16:07:27 +0000
commit25b1bd5ff49902ff6ffaf780a23571fe8f2f8e22 (patch)
treeed270fb7a7239f122f440cde07679951c279cd01 /biology
parent5f8c55ba37f6d291f5c2032016d4454be185e5e9 (diff)
downloadports-25b1bd5ff49902ff6ffaf780a23571fe8f2f8e22.tar.gz
ports-25b1bd5ff49902ff6ffaf780a23571fe8f2f8e22.zip
mark some of the ports that don't build on powerpc64 for me
Notes
Notes: svn path=/head/; revision=403676
Diffstat (limited to 'biology')
-rw-r--r--biology/avida/Makefile1
-rw-r--r--biology/bwa/Makefile2
-rw-r--r--biology/gmap/Makefile2
-rw-r--r--biology/muscle/Makefile2
4 files changed, 7 insertions, 0 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index 6ba9b2abca10..073609bd5c8b 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -13,6 +13,7 @@ COMMENT= Auto-adaptive genetic system designed for ALife research
LICENSE= GPLv3
BROKEN_sparc64= missing atomics implementation
+BROKEN_powerpc64= Does not build on powerpc64
USES= cmake:outsource ncurses
CMAKE_ARGS= -DAPTO_UNIT_TESTS:BOOL=OFF -DAVD_UNIT_TESTS:BOOL=OFF
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
index 75dc506030a9..3dfa08543049 100644
--- a/biology/bwa/Makefile
+++ b/biology/bwa/Makefile
@@ -20,6 +20,8 @@ PLIST_FILES= bin/bwa bin/qualfa2fq.pl bin/xa2multi.pl man/man1/bwa.1.gz
# Avoid #error in emmintrin.h
CFLAGS+= -msse2
+BROKEN_powerpc64= Does not build on powerpc64
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bwa ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${STAGEDIR}${PREFIX}/bin
diff --git a/biology/gmap/Makefile b/biology/gmap/Makefile
index 9dddd40698d0..3c308f9884e1 100644
--- a/biology/gmap/Makefile
+++ b/biology/gmap/Makefile
@@ -24,6 +24,8 @@ OPTIONS_DEFINE= SIMD
SIMD_CONFIGURE_OFF= --disable-builtin-popcount --disable-simd
+BROKEN_powerpc64= Does not build on powerpc64
+
# shebang_fix operates during patch.
# These scripts are created during configure.
post-configure:
diff --git a/biology/muscle/Makefile b/biology/muscle/Makefile
index 83033be028a7..314aedf3d971 100644
--- a/biology/muscle/Makefile
+++ b/biology/muscle/Makefile
@@ -21,6 +21,8 @@ ALL_TARGET= muscle
PLIST_FILES= bin/muscle
+BROKEN_powerpc64= Does not build on powerpc64
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/muscle ${STAGEDIR}${PREFIX}/bin