aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-16 21:03:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-16 21:04:16 +0000
commit2aa37d819d48330c1f0e97c95aeb92371ea06690 (patch)
tree327c43bdfbaba522503a5eafd6eab37a86fb20ce /biology
parent5dce9d0f2361d20a5cbe8dc2ad1fd2a321989ded (diff)
downloadports-2aa37d819d48330c1f0e97c95aeb92371ea06690.tar.gz
ports-2aa37d819d48330c1f0e97c95aeb92371ea06690.zip
New port: biology/seqkit: Cross-platform and ultrafast toolkit for FASTA/Q file manipulation
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/seqkit/Makefile19
-rw-r--r--biology/seqkit/distinfo5
-rw-r--r--biology/seqkit/pkg-descr17
4 files changed, 42 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 606e1982ee9b..adb71952bb1e 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -161,6 +161,7 @@
SUBDIR += seqan-apps
SUBDIR += seqan1
SUBDIR += seqio
+ SUBDIR += seqkit
SUBDIR += seqtk
SUBDIR += sim4
SUBDIR += slclust
diff --git a/biology/seqkit/Makefile b/biology/seqkit/Makefile
new file mode 100644
index 000000000000..4551cddb0836
--- /dev/null
+++ b/biology/seqkit/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= seqkit
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.16.0
+CATEGORIES= biology
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Cross-platform and ultrafast toolkit for FASTA/Q file manipulation
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/shenwei356/seqkit
+GO_TARGET= ./${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/biology/seqkit/distinfo b/biology/seqkit/distinfo
new file mode 100644
index 000000000000..b24424ffad25
--- /dev/null
+++ b/biology/seqkit/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1618605249
+SHA256 (go/biology_seqkit/seqkit-v0.16.0/v0.16.0.mod) = 2b29e40d7d4b891b1ece058363b9b4f8b3ba6385aa2855fb8d5f3df25bc83057
+SIZE (go/biology_seqkit/seqkit-v0.16.0/v0.16.0.mod) = 1211
+SHA256 (go/biology_seqkit/seqkit-v0.16.0/v0.16.0.zip) = 91fe05c0ead7b5dfafea7a0b3793583a3190befdcf3165735bf152182d0b0b11
+SIZE (go/biology_seqkit/seqkit-v0.16.0/v0.16.0.zip) = 29977829
diff --git a/biology/seqkit/pkg-descr b/biology/seqkit/pkg-descr
new file mode 100644
index 000000000000..12fde7f0b3b6
--- /dev/null
+++ b/biology/seqkit/pkg-descr
@@ -0,0 +1,17 @@
+FASTA and FASTQ are basic and ubiquitous formats for storing nucleotide and
+protein sequences. Common manipulations of FASTA/Q file include converting,
+searching, filtering, deduplication, splitting, shuffling, and sampling.
+Existing tools only implement some of these manipulations, and not particularly
+efficiently, and some are only available for certain operating systems.
+Furthermore, the complicated installation process of required packages and
+running environments can render these programs less user friendly.
+
+SeqKit is a cross-platform ultrafast comprehensive toolkit for FASTA/Q
+processing. SeqKit provides executable binary files for all major operating
+systems, including Windows, Linux, and Mac OS X, and can be directly used
+without any dependencies or pre-configurations. SeqKit demonstrates competitive
+performance in execution time and memory usage compared to similar tools. The
+efficiency and usability of SeqKit enable researchers to rapidly accomplish
+common FASTA/Q file manipulations.
+
+WWW: https://github.com/shenwei356/seqkit