aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-21 01:10:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-21 01:10:13 +0000
commit442b6b908d9dc0eb2d3bb886e72371846215e269 (patch)
treef2a229f5478b1e6a514433b6efa0f7b45115ac66 /biology
parent71e5d77a313f86d958d0dcadae3ba97a94da1896 (diff)
downloadports-442b6b908d9dc0eb2d3bb886e72371846215e269.tar.gz
ports-442b6b908d9dc0eb2d3bb886e72371846215e269.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/phyml/Makefile31
-rw-r--r--biology/phyml/distinfo3
-rw-r--r--biology/phyml/files/patch-src-configure11
-rw-r--r--biology/phyml/files/patch-src-configure.ac11
-rw-r--r--biology/phyml/pkg-descr18
6 files changed, 75 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index f5e23b38502c..d0530b57fe5a 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -70,6 +70,7 @@
SUBDIR += phrap
SUBDIR += phred
SUBDIR += phylip
+ SUBDIR += phyml
SUBDIR += platon
SUBDIR += povchem
SUBDIR += primer3
diff --git a/biology/phyml/Makefile b/biology/phyml/Makefile
new file mode 100644
index 000000000000..72646fd66fe8
--- /dev/null
+++ b/biology/phyml/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: phyml 3.0 20090706
+# Date created: July 17, 2009
+# Whom: ballen
+#
+# $FreeBSD$
+#
+
+PORTNAME= phyml
+PORTVERSION= 20090706
+CATEGORIES= biology
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= phyml_20090706
+
+MAINTAINER= ben@sysadminschronicles.com
+COMMENT= A simple, fast, and accurate algorithm to estimate large phylogenies
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/phyml
+USE_AUTOTOOLS= automake:110 aclocal:110
+AUTOMAKE_ARGS= --add-missing
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${RM} ${WRKSRC}/missing
+
+pre-install:
+ ${CHMOD} a+x ${WRKSRC}/install-sh
+
+.include <bsd.port.post.mk>
diff --git a/biology/phyml/distinfo b/biology/phyml/distinfo
new file mode 100644
index 000000000000..a523a466bf10
--- /dev/null
+++ b/biology/phyml/distinfo
@@ -0,0 +1,3 @@
+MD5 (phyml_20090706.tar.gz) = 70e9963a04f5423124793467e8b50be0
+SHA256 (phyml_20090706.tar.gz) = b39fa8ba2bc3a6566f3463c77db0d8992f71a71af353be539d0916173785d4bd
+SIZE (phyml_20090706.tar.gz) = 818229
diff --git a/biology/phyml/files/patch-src-configure b/biology/phyml/files/patch-src-configure
new file mode 100644
index 000000000000..dbd05af4a45a
--- /dev/null
+++ b/biology/phyml/files/patch-src-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2009-07-20 16:01:12.000000000 -0400
++++ configure 2009-07-20 16:02:03.000000000 -0400
+@@ -5491,8 +5491,6 @@
+ esac
+ # End of cross-compilation macros
+
+-CFLAGS+=" -O3 -fomit-frame-pointer -funroll-loops -Wall"
+-
+ ac_config_files="$ac_config_files Makefile"
+
+ cat >confcache <<\_ACEOF
diff --git a/biology/phyml/files/patch-src-configure.ac b/biology/phyml/files/patch-src-configure.ac
new file mode 100644
index 000000000000..da1f2449db83
--- /dev/null
+++ b/biology/phyml/files/patch-src-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2009-07-17 14:57:39.000000000 -0600
++++ configure.ac 2009-07-17 14:57:55.000000000 -0600
+@@ -58,8 +58,6 @@
+ esac
+ # End of cross-compilation macros
+
+-CFLAGS+=" -O3 -fomit-frame-pointer -funroll-loops -Wall"
+-
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
+
diff --git a/biology/phyml/pkg-descr b/biology/phyml/pkg-descr
new file mode 100644
index 000000000000..4e2aa57579c7
--- /dev/null
+++ b/biology/phyml/pkg-descr
@@ -0,0 +1,18 @@
+PhyML is a software that estimates maximum likelihood phylogenies from
+alignments of nucleotide or amino acid sequences. It provides a wide range of
+options that were designed to facilitate standard phylogenetic analyses. The
+main strengths of PhyML lies in the large number of substitution models coupled
+to various options to search the space of phylogenetic tree topologies, going
+from very fast and efficient methods to slower but generally more accurate
+approaches. It also implements two methods to evaluate branch supports in a
+sound statistical framework (the non-parametric bootstrap and the approximate
+likelihood ratio test). PhyML was designed to process moderate to large data
+sets. In theory, alignments with up to 4,000 sequences 2,000,000 character-long
+can analyzed. In practice however, the amount of memory required to process a
+data set is proportional of the product of the number of sequences by their
+length. Hence, a large number of sequences can only be processed provided that
+they are short. Also, PhyML can handle long sequences provided that they are
+not numerous. With most standard personal computers, the "comfort zone" for
+PhyML generally lies around 3 to 500 sequences less than 2,000 character long.
+
+WWW: http://code.google.com/p/phyml/