aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-06-14 16:40:33 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-06-14 16:40:33 +0000
commit5a2a6eb32954aa49c79269b08fd7e26ca4436f3d (patch)
treed87041c182697fed23828290b8b6c1d0c34c38b8 /biology
parentae98b790430fdbf2a036bb46112d6d0950d9606f (diff)
downloadports-5a2a6eb32954aa49c79269b08fd7e26ca4436f3d.tar.gz
ports-5a2a6eb32954aa49c79269b08fd7e26ca4436f3d.zip
biology/peak-classifier: Classify peaks based on GFF features
Classify ChIP/ATAC-Seq peaks based on features provided in a GFF Peaks are provided in a BED file sorted by chromosome and position. The GFF must be sorted by chromosome and position, with gene-level features separated by ### tags and each gene organized into subfeatures such as transcripts and exons. This is the default for common data sources.
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/peak-classifier/Makefile24
-rw-r--r--biology/peak-classifier/distinfo3
-rw-r--r--biology/peak-classifier/pkg-descr8
-rw-r--r--biology/peak-classifier/pkg-plist9
5 files changed, 45 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 4025c269aef3..4acd54fab965 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -112,6 +112,7 @@
SUBDIR += paml
SUBDIR += pbbam
SUBDIR += pbseqan
+ SUBDIR += peak-classifier
SUBDIR += pear-merger
SUBDIR += phrap
SUBDIR += phred
diff --git a/biology/peak-classifier/Makefile b/biology/peak-classifier/Makefile
new file mode 100644
index 000000000000..e964f1b7b49a
--- /dev/null
+++ b/biology/peak-classifier/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= peak-classifier
+DISTVERSION= 0.1.1
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Classify ChIP/ATAC-Seq peaks based on features provided in a GFF
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libxtend.so:devel/libxtend libbiolibc.so:biology/biolibc
+RUN_DEPENDS= bedtools:biology/bedtools \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
+
+USES= localbase python:3.7+ shebangfix
+USE_GITHUB= yes
+
+GH_ACCOUNT= auerlab
+SHEBANG_FILES= feature-view.py
+
+pre-build:
+ cd ${WRKSRC} && make depend LOCALBASE=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/biology/peak-classifier/distinfo b/biology/peak-classifier/distinfo
new file mode 100644
index 000000000000..43f3d37e76fb
--- /dev/null
+++ b/biology/peak-classifier/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623687381
+SHA256 (auerlab-peak-classifier-0.1.1_GH0.tar.gz) = 45230d50f204ecf1fa0f8bb1c96f00c25d84ae592b8def1cf053a07de60a8c7b
+SIZE (auerlab-peak-classifier-0.1.1_GH0.tar.gz) = 86012
diff --git a/biology/peak-classifier/pkg-descr b/biology/peak-classifier/pkg-descr
new file mode 100644
index 000000000000..b123dcbc554d
--- /dev/null
+++ b/biology/peak-classifier/pkg-descr
@@ -0,0 +1,8 @@
+Classify ChIP/ATAC-Seq peaks based on features provided in a GFF
+
+Peaks are provided in a BED file sorted by chromosome and position. The GFF
+must be sorted by chromosome and position, with gene-level features separated
+by ### tags and each gene organized into subfeatures such as transcripts and
+exons. This is the default for common data sources.
+
+WWW: https://github.com/auerlab/peak-classifier
diff --git a/biology/peak-classifier/pkg-plist b/biology/peak-classifier/pkg-plist
new file mode 100644
index 000000000000..787333471195
--- /dev/null
+++ b/biology/peak-classifier/pkg-plist
@@ -0,0 +1,9 @@
+bin/extract-genes
+bin/feature-view
+bin/filter-overlaps
+bin/peak-classifier
+libexec/extract-genes.awk
+man/man1/extract-genes.1.gz
+man/man1/feature-view.1.gz
+man/man1/filter-overlaps.1.gz
+man/man1/peak-classifier.1.gz