aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-06 09:53:56 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-04-06 09:53:56 +0000
commit5b92ed01d91a2fa9932769a56436c597770ae839 (patch)
tree06715147835302d4a8cb8c27523c611c07a92259 /biology
parent2ffa084df93c5ae30d1ce0a9fba1f4f0c902212e (diff)
downloadports-5b92ed01d91a2fa9932769a56436c597770ae839.tar.gz
ports-5b92ed01d91a2fa9932769a56436c597770ae839.zip
biology/trimadap: fix build on powerpc64le
Requires GCC for its SSE translation.
Diffstat (limited to 'biology')
-rw-r--r--biology/trimadap/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/biology/trimadap/Makefile b/biology/trimadap/Makefile
index e5cb61388546..6c58fc954970 100644
--- a/biology/trimadap/Makefile
+++ b/biology/trimadap/Makefile
@@ -10,7 +10,7 @@ COMMENT= Trim adapter sequences from Illumina data using heuristic rules
LICENSE= GPLv2
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= amd64 i386 powerpc64le
ONLY_FOR_ARCHS_REASON= Hard-coded SSE instructions
USE_GITHUB= yes
@@ -20,6 +20,13 @@ PLIST_FILES= bin/trimadap-mt
CFLAGS_i386= -msse2
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64le
+CFLAGS+= -DNO_WARN_X86_INTRINSICS
+USES= compiler:gcc-c++11-lib
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/trimadap-mt ${STAGEDIR}${PREFIX}/bin