aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-03-23 16:32:29 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-03-23 16:32:29 +0000
commit633c71fbf74172270dbd775c00b3b6f7e46f4ed1 (patch)
treefb4bd20fd4f1edd33262d9bcea50ecc579f624c2 /biology
parent9b3ddc8d58f9b4092c1b944c7cc357916c985b94 (diff)
downloadports-633c71fbf74172270dbd775c00b3b6f7e46f4ed1.tar.gz
ports-633c71fbf74172270dbd775c00b3b6f7e46f4ed1.zip
biology/vcf2hap: Generate .hap file from VCF for haplohseq
vcf2hap is a simple tool for generating a .hap file from a VCF. The .hap file is required by haplohseq. vcf2hap is extremely fast and requires a trivial amount of memory regardless of the size of the VCF file.
Notes
Notes: svn path=/head/; revision=569036
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/vcf2hap/Makefile26
-rw-r--r--biology/vcf2hap/distinfo3
-rw-r--r--biology/vcf2hap/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 260d2763d896..3ef12bfb358a 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -181,6 +181,7 @@
SUBDIR += trimmomatic
SUBDIR += ugene
SUBDIR += vcf-split
+ SUBDIR += vcf2hap
SUBDIR += vcflib
SUBDIR += vcftools
SUBDIR += velvet
diff --git a/biology/vcf2hap/Makefile b/biology/vcf2hap/Makefile
new file mode 100644
index 000000000000..bb4a4bd88103
--- /dev/null
+++ b/biology/vcf2hap/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= vcf2hap
+DISTVERSION= 0.1.2
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Generate .hap file from VCF for haplohseq
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= biolibc>=0.1.1:biology/biolibc
+
+USE_GITHUB= yes
+GH_ACCOUNT= auerlab
+
+PLIST_FILES= bin/vcf2hap man/man1/vcf2hap.1.gz
+
+pre-build:
+ (cd ${WRKSRC} && ${MAKE} LOCALBASE=${LOCALBASE} depend)
+
+do-test:
+ (cd ${WRKSRC}/Test && ./run-test.sh)
+
+.include <bsd.port.mk>
diff --git a/biology/vcf2hap/distinfo b/biology/vcf2hap/distinfo
new file mode 100644
index 000000000000..7b288bf922c7
--- /dev/null
+++ b/biology/vcf2hap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1616515046
+SHA256 (auerlab-vcf2hap-0.1.2_GH0.tar.gz) = 69804e605bdf646582cbc33bb2839387da5cb2e8a3f83a8a03b5a464d01348f1
+SIZE (auerlab-vcf2hap-0.1.2_GH0.tar.gz) = 197782
diff --git a/biology/vcf2hap/pkg-descr b/biology/vcf2hap/pkg-descr
new file mode 100644
index 000000000000..540a5393a487
--- /dev/null
+++ b/biology/vcf2hap/pkg-descr
@@ -0,0 +1,5 @@
+vcf2hap is a simple tool for generating a .hap file from a VCF. The .hap file
+is required by haplohseq. vcf2hap is extremely fast and requires a trivial
+amount of memory regardless of the size of the VCF file.
+
+WWW: https://github.com/auerlab/vcf2hap