aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-29 21:51:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-29 21:51:03 +0000
commit6393f0979a63be7ff5dc4495ed1c5741a89b7f13 (patch)
treed7185d7c6472df254c99a018d487a84ad6120e1c /biology
parent9a328b522a013b3206f83288e4c347ea754b6be7 (diff)
downloadports-6393f0979a63be7ff5dc4495ed1c5741a89b7f13.tar.gz
ports-6393f0979a63be7ff5dc4495ed1c5741a89b7f13.zip
biology/molden: Fix build with gfortran10
Notes
Notes: svn path=/head/; revision=569522
Diffstat (limited to 'biology')
-rw-r--r--biology/molden/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/biology/molden/Makefile b/biology/molden/Makefile
index 3215b6e7eb69..48cf9422f402 100644
--- a/biology/molden/Makefile
+++ b/biology/molden/Makefile
@@ -73,4 +73,12 @@ do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch between actual argument at (1) and actual argument at (2) (INTEGER(4)/REAL(4)).
+# in theory, this should set FCFLAGS, but the port does not conform
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
+.include <bsd.port.post.mk>