aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-05-02 12:41:44 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-05-02 12:41:44 +0000
commit642c8ce78f9f4d399d09b4f0abebb684354f3582 (patch)
treeb66c0e33c829a159f4f392f604f1c72364d58180 /biology
parent314168b9bec761c84cb4287892c09a3e43e1a5bc (diff)
downloadports-642c8ce78f9f4d399d09b4f0abebb684354f3582.tar.gz
ports-642c8ce78f9f4d399d09b4f0abebb684354f3582.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/ncbi-toolkit/Makefile8
-rw-r--r--biology/ncbi-toolkit/files/patch-make-makeall.unx13
-rw-r--r--biology/ncbi-toolkit/files/patch-make-makenet.unx58
3 files changed, 72 insertions, 7 deletions
diff --git a/biology/ncbi-toolkit/Makefile b/biology/ncbi-toolkit/Makefile
index 6b15b9e1cf8d..d890f2ab5275 100644
--- a/biology/ncbi-toolkit/Makefile
+++ b/biology/ncbi-toolkit/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ncbi-toolkit
PORTVERSION= 2009.03.01 # containing BLAST v2.2.19
+PORTREVISION= 1
CATEGORIES= biology
MASTER_SITES= ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools/old/${PORTVERSION:S/.//g}/
DISTNAME= ncbi
@@ -42,13 +43,6 @@ BLAST_EXE= bl2seq blastall blastcl3 blastclust blastpgp copymat \
X11_EXE= Nentrez Psequin ddv entrez2 sbtedit udv
# and these are the man pages we have
-MAN1= asn2asn.1 asn2ff.1 asn2fsa.1 asn2gb.1 asn2idx.1 asn2xml.1 \
- asndhuff.1 asnval.1 blast.1 blastclust.1 cdscan.1 checksub.1 \
- copymat.1 ddv.1 debruijn.1 errhdr.1 fa2htgs.1 fastacmd.1 \
- findspl.1 fmerge.1 formatdb.1 getmesh.1 getpub.1 gil2bin.1 \
- idfetch.1 indexpub.1 makemat.1 makeset.1 sbtedit.1 tbl2asn.1 \
- udv.1 vecscreen.1 Psequin.1 asn2all.1 asntool.1 entrez2.1 \
- formatrpsdb.1
MAN1= Psequin.1 asn2all.1 asn2asn.1 asn2ff.1 asn2fsa.1 asn2gb.1 asn2idx.1 \
asn2xml.1 asndhuff.1 asntool.1 asnval.1 blast.1 blastclust.1 \
cdscan.1 checksub.1 copymat.1 ddv.1 \
diff --git a/biology/ncbi-toolkit/files/patch-make-makeall.unx b/biology/ncbi-toolkit/files/patch-make-makeall.unx
new file mode 100644
index 000000000000..2c46de62b96f
--- /dev/null
+++ b/biology/ncbi-toolkit/files/patch-make-makeall.unx
@@ -0,0 +1,13 @@
+--- make/makeall.unx.orig 2011-04-13 20:40:11.451542049 +0400
++++ make/makeall.unx 2011-04-13 20:41:03.081658892 +0400
+@@ -64,8 +64,8 @@
+ CC = cc
+ RAN = ls -l
+ AR=ar
+-OTHERLIBS = -lm
+-VIBLIBS =
++OTHERLIBS = -lm -liconv
++VIBLIBS = -lXft -lpng -ljpeg
+ VIBFLAG =
+ LIBCOPY = cp -p
+ SRCCOPY = ./ln-if-absent
diff --git a/biology/ncbi-toolkit/files/patch-make-makenet.unx b/biology/ncbi-toolkit/files/patch-make-makenet.unx
new file mode 100644
index 000000000000..76d817d6c913
--- /dev/null
+++ b/biology/ncbi-toolkit/files/patch-make-makenet.unx
@@ -0,0 +1,58 @@
+--- make/makenet.unx.orig 2008-12-11 00:23:29.000000000 +0300
++++ make/makenet.unx 2011-04-14 00:26:38.440426134 +0400
+@@ -67,6 +67,7 @@
+ VIB =
+ VIBLIBS= -lXm -lXmu -lXt -lX11
+ VIBLIBS=
++USERLIBS = -lXft -lpng -ljpeg -liconv
+ SEQUIN_OPTS =
+ LIBCOPY = cp -p
+ SRCCOPY = ./ln-if-absent
+@@ -923,17 +924,17 @@
+ $(CC) -o ddv $(LDFLAGS) $(OBJDDV) $(LIB41) $(LIB31) $(LIB20) $(LIB61) $(LIB60) $(LIB22) $(LIB45) \
+ $(LIB8) $(LIB7) $(NETCLILIB) $(LIB3) $(LIB4) $(LIB23) \
+ $(LIBCOMPADJ) $(LIB2) $(LIB1) \
+- $(VIBLIBS) $(OTHERLIBS)
++ $(VIBLIBS) $(OTHERLIBS) $(USERLIBS)
+
+ udv : $(OBJUDV)
+ $(CC) -o udv $(LDFLAGS) $(OBJUDV) $(LIB41) $(LIB31) $(LIB20) $(LIB61) $(LIB60) $(LIB22) $(LIB45) \
+ $(LIB8) $(LIB7) $(NETCLILIB) $(LIB3) $(LIB4) \
+ $(LIB23) $(LIBCOMPADJ) $(LIB2) \
+- $(LIB1) $(VIBLIBS) $(OTHERLIBS)
++ $(LIB1) $(VIBLIBS) $(OTHERLIBS) $(USERLIBS)
+
+ Nentrez : entrez.c $(ULIB31)
+ $(CC) -o Nentrez $(LDFLAGS) entrez.c $(LIB41) $(LIB31) $(LIB30) $(LIB20) $(LIB61) $(LIB60) $(LIB22) $(LIB45) \
+- $(LIB36) $(LIB23) $(LIBCOMPADJ) $(LIB8) $(LIB7) $(NETCLILIB) $(LIB5) $(LIB4) $(LIB3) $(LIB2) $(LIB1) $(VIBLIBS) $(OTHERLIBS)
++ $(LIB36) $(LIB23) $(LIBCOMPADJ) $(LIB8) $(LIB7) $(NETCLILIB) $(LIB5) $(LIB4) $(LIB3) $(LIB2) $(LIB1) $(VIBLIBS) $(OTHERLIBS) $(USERLIBS)
+
+ # left this in (Tentrez) for script backwards compatibility
+ Tentrez : entrez.c $(ULIB31)
+@@ -1114,7 +1115,7 @@
+ entrez2 : entrez2.c
+ $(CC) -g -o entrez2 $(LDFLAGS) entrez2.c $(LIB41) $(LIB6) $(LIB20) \
+ $(LIB61) $(LIB60) $(LIB22) $(LIB23) $(LIBCOMPADJ) \
+- $(LIB2) $(LIB4) $(LIB1) $(VIBLIBS) $(OTHERLIBS)
++ $(LIB2) $(LIB4) $(LIB1) $(VIBLIBS) $(OTHERLIBS) $(USERLIBS)
+ $(VIB_POST_LINK) entrez2
+
+ # demo program (spidey)
+@@ -1383,7 +1384,7 @@
+ $(CC) -o Psequin -I. $(LDFLAGS) -UINTERNAL_NCBI_SEQUIN $(SRCSEQUIN) \
+ $(LIB30) $(LIB45) $(LIB31) $(LIB20) $(LIB61) $(LIB60) $(LIB22) \
+ $(LIB40) $(LIB41) $(LIB36) $(LIB23) $(LIBCOMPADJ) $(LIB11) \
+- $(ENTREZLIBS) $(LIB4) $(LIB2) $(LIB1) $(VIBLIBS) $(OTHERLIBS)
++ $(ENTREZLIBS) $(LIB4) $(LIB2) $(LIB1) $(VIBLIBS) $(OTHERLIBS) $(USERLIBS)
+ $(VIB_POST_LINK) Psequin
+
+ # 'sbtedit' Submission Template Editor
+@@ -1395,7 +1396,7 @@
+ $(CC) -o sbtedit -I. $(LDFLAGS) -UINTERNAL_NCBI_SEQUIN $(SRCSBTEDIT) \
+ $(LIB30) $(LIB45) $(LIB31) $(LIB20) $(LIB61) $(LIB60) $(LIB22) \
+ $(LIB40) $(LIB41) $(LIB36) $(LIB23) $(LIBCOMPADJ) $(LIB11) \
+- $(ENTREZLIBS) $(LIB4) $(LIB2) $(LIB1) $(VIBLIBS) $(OTHERLIBS)
++ $(ENTREZLIBS) $(LIB4) $(LIB2) $(LIB1) $(VIBLIBS) $(OTHERLIBS) $(USERLIBS)
+ $(VIB_POST_LINK) sbtedit
+
+ salogif.o: salogif.c