aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2021-12-05 10:38:43 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2021-12-12 18:46:22 +0000
commit68b99b391349672d7f70e7ac89d430b8dbe32850 (patch)
tree537d227bf77a71dd80b85d2b08dd8b40cdb40dae /biology
parent6bcd9d2f051da55e897d17ad5add3c91268faa4f (diff)
downloadports-68b99b391349672d7f70e7ac89d430b8dbe32850.tar.gz
ports-68b99b391349672d7f70e7ac89d430b8dbe32850.zip
Diffstat (limited to 'biology')
-rw-r--r--biology/cufflinks/files/patch-configure.ac21
-rw-r--r--biology/phyml/files/patch-configure.ac10
2 files changed, 29 insertions, 2 deletions
diff --git a/biology/cufflinks/files/patch-configure.ac b/biology/cufflinks/files/patch-configure.ac
index e40d507ff95b..5d8f553f27ad 100644
--- a/biology/cufflinks/files/patch-configure.ac
+++ b/biology/cufflinks/files/patch-configure.ac
@@ -1,6 +1,15 @@
---- configure.ac.orig 2019-05-29 06:53:24 UTC
+--- configure.ac.orig 2019-07-06 16:28:01 UTC
+++ configure.ac
-@@ -77,9 +77,10 @@ case "${host_cpu}-${host_os}" in
+@@ -14,7 +14,7 @@ AC_DEFINE(SVN_REVISION, "svnversion", [SVN Revision])
+ AC_CONFIG_SRCDIR([config.h.in])
+ AC_CONFIG_HEADERS([config.h])
+ AC_CONFIG_AUX_DIR([build-aux])
+-AM_INIT_AUTOMAKE
++AM_INIT_AUTOMAKE([-Wall tar-pax foreign])
+
+ #AM_PATH_CPPUNIT(1.10.2)
+
+@@ -78,9 +78,10 @@ case "${host_cpu}-${host_os}" in
AC_COMPILE_IFELSE([AC_LANG_PROGRAM], [ext_CFLAGS="-arch x86_64"], []);;
*)
AC_MSG_CHECKING([if gcc accepts -m64])
@@ -14,3 +23,11 @@
esac
AC_ARG_ENABLE(vectorize, [ --enable-vectorize Enable GCC auto-vectorization],
+@@ -120,7 +121,6 @@ LDFLAGS="${ext_LDFLAGS} ${user_LDFLAGS}"
+ AC_CHECK_MEMBERS([struct sysinfo.totalram], [], [], [#include <sys/sysinfo.h>])
+ AC_CHECK_DECLS([sysctl, CTL_HW, HW_PHYSMEM], [], [], [#include <sys/sysctl.h>])
+
+-AM_INIT_AUTOMAKE([-Wall tar-pax foreign])
+
+ AC_CONFIG_FILES([Makefile
+ src/Makefile])
diff --git a/biology/phyml/files/patch-configure.ac b/biology/phyml/files/patch-configure.ac
new file mode 100644
index 000000000000..c96d56cf91bc
--- /dev/null
+++ b/biology/phyml/files/patch-configure.ac
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2020-07-09 11:49:16 UTC
++++ configure.ac
+@@ -10,7 +10,6 @@ AC_CONFIG_HEADERS([config.h])
+ AC_DEFINE([UNIX],[1],[Unix tag on])
+ AC_DEFINE([DEBUG],[1],[Debug tag on])
+
+-AM_INIT_AUTOMAKE
+ AC_CANONICAL_HOST
+
+ AC_PROG_CC([gcc])