aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-03-20 17:14:32 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-03-20 17:14:32 +0000
commit6f516a8acf5122668b71a77d90e28cff1c3881e4 (patch)
tree74aa85b99a6dcff8050252330fb33340525ae72e /biology
parent1131956c47169cc9ba0e0809795e7021de6e7b3c (diff)
downloadports-6f516a8acf5122668b71a77d90e28cff1c3881e4.tar.gz
ports-6f516a8acf5122668b71a77d90e28cff1c3881e4.zip
biology/htslib: Update to 1.12
biology/samtools: Update to 1.12 biology/bcftools: Update to 1.12 Numerous enhancements, performance improvements, and bug fixes since 1.11 Build-tested all other htslib dependents, no revbumps should be needed Reported by: portscout
Notes
Notes: svn path=/head/; revision=568874
Diffstat (limited to 'biology')
-rw-r--r--biology/bcftools/Makefile5
-rw-r--r--biology/bcftools/distinfo6
-rw-r--r--biology/bcftools/files/patch-Makefile16
-rw-r--r--biology/bcftools/files/patch-test_test.pl20
-rw-r--r--biology/bcftools/files/pkg-message.in13
-rw-r--r--biology/bcftools/pkg-plist2
-rw-r--r--biology/htslib/Makefile8
-rw-r--r--biology/htslib/distinfo6
-rw-r--r--biology/htslib/files/patch-Makefile18
-rw-r--r--biology/htslib/files/patch-hfile__libcurl.c24
-rw-r--r--biology/htslib/files/patch-sam.c10
-rw-r--r--biology/htslib/pkg-plist3
-rw-r--r--biology/samtools/Makefile4
-rw-r--r--biology/samtools/distinfo6
-rw-r--r--biology/samtools/files/patch-Makefile18
-rw-r--r--biology/samtools/files/patch-test_test.pl20
-rw-r--r--biology/samtools/pkg-plist1
17 files changed, 32 insertions, 148 deletions
diff --git a/biology/bcftools/Makefile b/biology/bcftools/Makefile
index 964affb3cd6f..f70a8d828a2d 100644
--- a/biology/bcftools/Makefile
+++ b/biology/bcftools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bcftools
-PORTVERSION= 1.11
+PORTVERSION= 1.12
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -11,14 +11,13 @@ COMMENT= Tools for manipulating next-generation sequencing data
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libhts.so.3:biology/htslib
+LIB_DEPENDS= libhts.so:biology/htslib
TEST_DEPENDS= bash:shells/bash
RUN_DEPENDS= bash:shells/bash
USES= autoreconf gmake localbase perl5 python:env shebangfix
USE_GITHUB= yes
-USE_LDCONFIG= ${PREFIX}/libexec/${PORTNAME}
USE_PERL5= test
GH_ACCOUNT= samtools
diff --git a/biology/bcftools/distinfo b/biology/bcftools/distinfo
index aac1660e88f1..204108d9af60 100644
--- a/biology/bcftools/distinfo
+++ b/biology/bcftools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1603028344
-SHA256 (samtools-bcftools-1.11_GH0.tar.gz) = f2d9a09fd7920754b60948b81ec047882864213b93a0cd1ef0372b0e025cba3f
-SIZE (samtools-bcftools-1.11_GH0.tar.gz) = 3004923
+TIMESTAMP = 1616112968
+SHA256 (samtools-bcftools-1.12_GH0.tar.gz) = b29e6d41ca0bb3f1761bee81be0c423329928a724a75501641c1ac5065d65526
+SIZE (samtools-bcftools-1.12_GH0.tar.gz) = 3048508
diff --git a/biology/bcftools/files/patch-Makefile b/biology/bcftools/files/patch-Makefile
index 8dc6a8e96e69..3299954ae45b 100644
--- a/biology/bcftools/files/patch-Makefile
+++ b/biology/bcftools/files/patch-Makefile
@@ -1,16 +1,6 @@
---- Makefile.orig 2020-10-18 13:31:52 UTC
+--- Makefile.orig 2021-03-17 09:16:18 UTC
+++ Makefile
-@@ -45,7 +45,8 @@ OBJS = main.o vcfindex.o tabix.o \
- ccall.o em.o prob1.o kmin.o # the original samtools calling
- PLUGIN_OBJS = vcfplugin.o
-
--prefix = /usr/local
-+PREFIX ?= /usr/local
-+prefix = $(PREFIX)
- exec_prefix = $(prefix)
- bindir = $(exec_prefix)/bin
- libdir = $(exec_prefix)/lib
-@@ -58,13 +59,14 @@ pluginpath = $(plugindir)
+@@ -58,13 +58,14 @@ pluginpath = $(plugindir)
# Installation location for $(MISC_PROGRAMS) and $(MISC_SCRIPTS)
misc_bindir = $(bindir)
@@ -32,7 +22,7 @@
PROGRAMS = bcftools
MISC_SCRIPTS = \
-@@ -142,7 +144,7 @@ print-version:
+@@ -142,7 +143,7 @@ print-version:
ifdef USE_GPL
main.o : EXTRA_CPPFLAGS += -DUSE_GPL
OBJS += polysomy.o peakfit.o
diff --git a/biology/bcftools/files/patch-test_test.pl b/biology/bcftools/files/patch-test_test.pl
deleted file mode 100644
index 39ccb4466b54..000000000000
--- a/biology/bcftools/files/patch-test_test.pl
+++ /dev/null
@@ -1,20 +0,0 @@
---- test/test.pl.orig 2020-10-18 13:36:42 UTC
-+++ test/test.pl
-@@ -1236,7 +1236,7 @@ sub test_usage
- my $command = $args{cmd};
- my $commandpath = $$opts{bin}."/".$command;
- my ($ret,$out) = _cmd("$commandpath $args{redirection} 2>&1");
-- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
-+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
-
- my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
-
-@@ -1291,7 +1291,7 @@ sub test_usage_subcommand
- my $subcommand = $args{subcmd};
- my $commandpath = $$opts{bin}."/".$command;
- my ($ret,$out) = _cmd("$commandpath $subcommand $args{redirection} 2>&1");
-- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
-+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
-
- my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
-
diff --git a/biology/bcftools/files/pkg-message.in b/biology/bcftools/files/pkg-message.in
deleted file mode 100644
index 8bee64d8ea83..000000000000
--- a/biology/bcftools/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-[
-{ type: install
- message: <<EOM
-The miscellaneous tools included with Bcftools have been installed to
-%%PREFIX%%/bin/samtools_misc
-
-Add that directory to your path if you want to use these tools.
-
-Some of these tools depend on Perl5/Python, and it will need to be installed to
-use them.
-EOM
-}
-]
diff --git a/biology/bcftools/pkg-plist b/biology/bcftools/pkg-plist
index ed393533217b..11f94eafff86 100644
--- a/biology/bcftools/pkg-plist
+++ b/biology/bcftools/pkg-plist
@@ -40,7 +40,7 @@ libexec/bcftools/smpl-stats.so
libexec/bcftools/split-vep.so
libexec/bcftools/split.so
libexec/bcftools/tag2tag.so
-libexec/bcftools/trio-dnm.so
+libexec/bcftools/trio-dnm2.so
libexec/bcftools/trio-stats.so
libexec/bcftools/trio-switch-rate.so
libexec/bcftools/variantkey-hex.so
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
index 733ec0c41dea..17779dfd3503 100644
--- a/biology/htslib/Makefile
+++ b/biology/htslib/Makefile
@@ -2,8 +2,10 @@
# $FreeBSD$
PORTNAME= htslib
-DISTVERSION= 1.11.0
+DISTVERSION= 1.12
CATEGORIES= biology devel
+# Github generated distfiles are incomplete, so use custom tarball
+MASTER_SITES= https://github.com/samtools/htslib/releases/download/${DISTVERSION}/
MAINTAINER= jwb@FreeBSD.org
COMMENT= C library for high-throughput sequencing data formats
@@ -15,12 +17,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libdeflate.so:archivers/libdeflate
TEST_DEPENDS= bash:shells/bash
-USES= autoreconf gmake localbase pathfix perl5 shebangfix
-USE_GITHUB= yes
+USES= autoreconf gmake localbase pathfix perl5 shebangfix tar:bzip2
USE_PERL5= test
USE_LDCONFIG= yes
-GH_ACCOUNT= samtools
GNU_CONFIGURE= yes
PATHFIX_MAKEFILEIN= Makefile
SHEBANG_FILES= test/*.pl
diff --git a/biology/htslib/distinfo b/biology/htslib/distinfo
index ef59ac4df246..2bc449b5deb6 100644
--- a/biology/htslib/distinfo
+++ b/biology/htslib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602982298
-SHA256 (samtools-htslib-1.11.0_GH0.tar.gz) = 55356e78f25a20194488d94308335f409c3757101398961388caf38d3cce12dd
-SIZE (samtools-htslib-1.11.0_GH0.tar.gz) = 1485848
+TIMESTAMP = 1616112272
+SHA256 (htslib-1.12.tar.bz2) = 2280141b46e953ba4ae01b98335a84f8e6ccbdb6d5cdbab7f70ee4f7e3b6f4ca
+SIZE (htslib-1.12.tar.bz2) = 4094458
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
index 6f8216bbc7bb..7f91465d2ccd 100644
--- a/biology/htslib/files/patch-Makefile
+++ b/biology/htslib/files/patch-Makefile
@@ -1,16 +1,6 @@
---- Makefile.orig 2020-10-18 00:44:56 UTC
+--- Makefile.orig 2021-03-20 15:53:14 UTC
+++ Makefile
-@@ -40,7 +40,8 @@ EXTRA_CFLAGS_PIC = -fpic
- LDFLAGS = -fvisibility=hidden
- LIBS = $(htslib_default_libs)
-
--prefix = /usr/local
-+PREFIX ?= /usr/local
-+prefix = $(PREFIX)
- exec_prefix = $(prefix)
- bindir = $(exec_prefix)/bin
- includedir = $(prefix)/include
-@@ -53,13 +54,14 @@ man5dir = $(mandir)/man5
+@@ -53,13 +53,14 @@ man5dir = $(mandir)/man5
man7dir = $(mandir)/man7
pkgconfigdir= $(prefix)/libdata/pkgconfig
@@ -32,7 +22,7 @@
# Set by config.mk if plugins are enabled
plugindir =
-@@ -100,7 +102,7 @@ BUILT_THRASH_PROGRAMS = \
+@@ -102,7 +103,7 @@ BUILT_THRASH_PROGRAMS = \
test/thrash_threads6 \
test/thrash_threads7
@@ -40,4 +30,4 @@
+all: lib-static lib-shared $(BUILT_PROGRAMS) plugins \
htslib_static.mk htslib-uninstalled.pc
- HTSPREFIX =
+ ALL_CPPFLAGS = -I. $(CPPFLAGS)
diff --git a/biology/htslib/files/patch-hfile__libcurl.c b/biology/htslib/files/patch-hfile__libcurl.c
deleted file mode 100644
index 2406056b1c04..000000000000
--- a/biology/htslib/files/patch-hfile__libcurl.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- hfile_libcurl.c.orig 2020-09-22 12:15:49 UTC
-+++ hfile_libcurl.c
-@@ -22,6 +22,10 @@ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR O
- FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
- DEALINGS IN THE SOFTWARE. */
-
-+#ifndef ENOTRECOVERABLE
-+#define ENOTRECOVERABLE EIO
-+#endif
-+
- #define HTS_BUILDING_LIBRARY // Enables HTSLIB_EXPORT, see htslib/hts_defs.h
- #include <config.h>
-
-@@ -73,6 +77,10 @@ typedef struct {
- unsigned int num;
- unsigned int size;
- } hdrlist;
-+
-+#ifndef ENOTRECOVERABLE
-+#define ENOTRECOVERABLE EIO
-+#endif
-
- typedef struct {
- hdrlist fixed; // List of headers supplied at hopen()
diff --git a/biology/htslib/files/patch-sam.c b/biology/htslib/files/patch-sam.c
deleted file mode 100644
index 679b4d71967d..000000000000
--- a/biology/htslib/files/patch-sam.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- sam.c.orig 2020-10-18 00:50:46 UTC
-+++ sam.c
-@@ -35,6 +35,7 @@ DEALINGS IN THE SOFTWARE. */
- #include <assert.h>
- #include <signal.h>
- #include <inttypes.h>
-+#include <unistd.h> // usleep()
-
- // Suppress deprecation message for cigar_tab, which we initialise
- #include "htslib/hts_defs.h"
diff --git a/biology/htslib/pkg-plist b/biology/htslib/pkg-plist
index 06e7972133d5..e2ebe3a2e8d6 100644
--- a/biology/htslib/pkg-plist
+++ b/biology/htslib/pkg-plist
@@ -8,6 +8,7 @@ include/htslib/hfile.h
include/htslib/hts.h
include/htslib/hts_defs.h
include/htslib/hts_endian.h
+include/htslib/hts_expr.h
include/htslib/hts_log.h
include/htslib/hts_os.h
include/htslib/kbitset.h
@@ -30,7 +31,7 @@ include/htslib/vcf_sweep.h
include/htslib/vcfutils.h
lib/libhts.a
lib/libhts.so
-lib/libhts.so.1.11
+lib/libhts.so.%%PORTVERSION%%
lib/libhts.so.3
libdata/pkgconfig/htslib.pc
man/man1/bgzip.1.gz
diff --git a/biology/samtools/Makefile b/biology/samtools/Makefile
index 74b6236a030a..55bfe3dd5c12 100644
--- a/biology/samtools/Makefile
+++ b/biology/samtools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= samtools
-DISTVERSION= 1.11
+DISTVERSION= 1.12
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -11,7 +11,7 @@ COMMENT= Tools for manipulating next-generation sequencing data
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libhts.so.3:biology/htslib
+LIB_DEPENDS= libhts.so:biology/htslib
TEST_DEPENDS= bash:shells/bash
USES= autoreconf gmake localbase ncurses perl5 python:env shebangfix
diff --git a/biology/samtools/distinfo b/biology/samtools/distinfo
index d0c046e7d011..08b69e957221 100644
--- a/biology/samtools/distinfo
+++ b/biology/samtools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602982679
-SHA256 (samtools-samtools-1.11_GH0.tar.gz) = 80a54e93c5d111c15c005ee96a578bcd7e1bde34dba2242d981c539ff32f1738
-SIZE (samtools-samtools-1.11_GH0.tar.gz) = 4516328
+TIMESTAMP = 1616112844
+SHA256 (samtools-samtools-1.12_GH0.tar.gz) = a31695aca88b6acf52e1b579d84edb6b54f7b1b22227aad1ef6c6ccdd10314cf
+SIZE (samtools-samtools-1.12_GH0.tar.gz) = 4528460
diff --git a/biology/samtools/files/patch-Makefile b/biology/samtools/files/patch-Makefile
index 3a175dd2115b..de890df5e224 100644
--- a/biology/samtools/files/patch-Makefile
+++ b/biology/samtools/files/patch-Makefile
@@ -1,16 +1,6 @@
---- Makefile.orig 2020-10-18 00:55:50 UTC
+--- Makefile.orig 2021-03-17 09:14:26 UTC
+++ Makefile
-@@ -49,7 +49,8 @@ AOBJS= bam_index.o bam_plcmd.o sam_view.o bam_fas
- bam_ampliconclip.o amplicon_stats.o
- LZ4OBJS = $(LZ4DIR)/lz4.o
-
--prefix = /usr/local
-+PREFIX ?= /usr/local
-+prefix = $(PREFIX)
- exec_prefix = $(prefix)
- bindir = $(exec_prefix)/bin
- datarootdir = $(prefix)/share
-@@ -59,14 +60,14 @@ man1dir = $(mandir)/man1
+@@ -59,14 +59,14 @@ man1dir = $(mandir)/man1
# Installation location for $(MISC_PROGRAMS) and $(MISC_SCRIPTS)
misc_bindir = $(bindir)
@@ -23,8 +13,8 @@
-INSTALL_SCRIPT = $(INSTALL_PROGRAM)
-
+# Use BSD_INSTALL_PROGRAM to strip when WITH_DEBUG not set
-+MKDIR_P = mkdir -p
-+INSTALL = install -p
++MKDIR_P = mkdir -p
++INSTALL = install -p
+INSTALL_DATA = ${BSD_INSTALL_DATA}
+INSTALL_DIR = $(MKDIR_P)
+INSTALL_MAN = ${BSD_INSTALL_MAN}
diff --git a/biology/samtools/files/patch-test_test.pl b/biology/samtools/files/patch-test_test.pl
deleted file mode 100644
index 8800086e39b0..000000000000
--- a/biology/samtools/files/patch-test_test.pl
+++ /dev/null
@@ -1,20 +0,0 @@
---- test/test.pl.orig 2020-07-21 20:48:50 UTC
-+++ test/test.pl
-@@ -907,7 +907,7 @@ sub test_usage
- my $command = $args{cmd};
- my $commandpath = $$opts{bin}."/".$command;
- my ($ret,$out,$err) = _cmd("$commandpath $args{redirection}");
-- if ( $err =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath: $out"); return; }
-+ if ( $err =~ m/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath: $out"); return; }
-
- my @sections = ($err =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
-
-@@ -965,7 +965,7 @@ sub test_usage_subcommand
- my $commandpath = $$opts{bin}."/".$command;
- my ($ret,$out,$err) = _cmd("$commandpath $subcommand $args{redirection}");
-
-- if ( $err =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath $subcommand: $out"); return; }
-+ if ( $err =~ m/bash.*no.*such/i ) { failed($opts,msg=>$test,reason=>"could not run $commandpath $subcommand: $out"); return; }
-
- if ( $err =~ m/not.*implemented/is ) { failed($opts,msg=>$test,reason=>"subcommand indicates it is not implemented",expect_fail=>1); return; }
-
diff --git a/biology/samtools/pkg-plist b/biology/samtools/pkg-plist
index 4c35d4bb0e69..19b73d4ab8e7 100644
--- a/biology/samtools/pkg-plist
+++ b/biology/samtools/pkg-plist
@@ -2,6 +2,7 @@ bin/ace2sam
bin/blast2sam.pl
bin/bowtie2sam.pl
bin/export2sam.pl
+bin/fasta-sanitize.pl
bin/interpolate_sam.pl
bin/maq2sam-long
bin/maq2sam-short