aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-03-23 15:15:00 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-03-23 15:15:00 +0000
commitaa8e14f1c183bdc57940de974b9773b498595974 (patch)
tree8975f218155bc5451f968db6b12d5b18b128f803 /biology
parentd20299d14c70387e5f3f69ebbdacee90272809a1 (diff)
downloadports-aa8e14f1c183bdc57940de974b9773b498595974.tar.gz
ports-aa8e14f1c183bdc57940de974b9773b498595974.zip
biology/ad2vcf: Add allelic depth info from a SAM stream to a VCF file
ad2vdf extracts allelic depth info from a SAM stream and adds it to a corresponding single-sample VCF file. SAM input is read via stdin and the VCF input file is taken as a command-line argument. This allows expensive BAM/CRAM decoding to be performed in parallel by a separate samtools process.
Notes
Notes: svn path=/head/; revision=569033
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/ad2vcf/Makefile26
-rw-r--r--biology/ad2vcf/distinfo3
-rw-r--r--biology/ad2vcf/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index cba970a40784..260d2763d896 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -4,6 +4,7 @@
COMMENT = Biology
SUBDIR += abyss
+ SUBDIR += ad2vcf
SUBDIR += artemis
SUBDIR += avida
SUBDIR += babel
diff --git a/biology/ad2vcf/Makefile b/biology/ad2vcf/Makefile
new file mode 100644
index 000000000000..e3703746263e
--- /dev/null
+++ b/biology/ad2vcf/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= ad2vcf
+DISTVERSION= 0.1.2
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Add allelic depth info from a SAM stream to a VCF file
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= biolibc>=0.1.1:biology/biolibc
+
+USE_GITHUB= yes
+GH_ACCOUNT= auerlab
+
+PLIST_FILES= bin/ad2vcf man/man1/ad2vcf.1.gz
+
+pre-build:
+ (cd ${WRKSRC} && ${MAKE} LOCALBASE=${LOCALBASE} depend)
+
+do-test:
+ (cd ${WRKSRC}/Test && ./run-test.sh)
+
+.include <bsd.port.mk>
diff --git a/biology/ad2vcf/distinfo b/biology/ad2vcf/distinfo
new file mode 100644
index 000000000000..649dbb04a74c
--- /dev/null
+++ b/biology/ad2vcf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1616510305
+SHA256 (auerlab-ad2vcf-0.1.2_GH0.tar.gz) = e85e221c69748082799f5b048412136d28a0395290b16728500fe30190eaea84
+SIZE (auerlab-ad2vcf-0.1.2_GH0.tar.gz) = 15204
diff --git a/biology/ad2vcf/pkg-descr b/biology/ad2vcf/pkg-descr
new file mode 100644
index 000000000000..21df7c875513
--- /dev/null
+++ b/biology/ad2vcf/pkg-descr
@@ -0,0 +1,6 @@
+ad2vdf extracts allelic depth info from a SAM stream and adds it to a
+corresponding single-sample VCF file. SAM input is read via stdin and the VCF
+input file is taken as a command-line argument. This allows expensive BAM/CRAM
+decoding to be performed in parallel by a separate samtools process.
+
+WWW: https://github.com/auerlab/ad2vcf