aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-05-13 03:35:51 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-05-13 03:35:51 +0000
commitba601f25ac232b149cd091af813e9eab852a447b (patch)
tree0e89021fd44a8edda1d97d4e3b9b90599d254d40 /biology
parent65cfb4ff6eb45936d6d0f8abedf0a4b25781a555 (diff)
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/avida/Makefile2
-rw-r--r--biology/bwa/Makefile1
-rw-r--r--biology/gmap/Makefile2
-rw-r--r--biology/iolib/Makefile2
-rw-r--r--biology/plinkseq/Makefile2
5 files changed, 6 insertions, 3 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index be08e312e5de..550715afe2a0 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -17,7 +17,7 @@ BROKEN_armv6= invokes x86 asm
BROKEN_mips= invokes x86 asm
BROKEN_mips64= invokes x86 asm
BROKEN_sparc64= missing atomics implementation
-BROKEN_powerpc64= Does not build on powerpc64
+BROKEN_powerpc64= fails to compile: sibling call optimization does not allow automatic multiple TOCs
USES= cmake:outsource ncurses
CMAKE_ARGS= -DAPTO_UNIT_TESTS:BOOL=OFF \
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
index a20f1209ac52..163cc1ce9e03 100644
--- a/biology/bwa/Makefile
+++ b/biology/bwa/Makefile
@@ -12,6 +12,7 @@ COMMENT= Burrows-Wheeler sequence aligner
LICENSE= GPLv3
BROKEN_aarch64= fails to compile: error: invalid conversion between vector type and integer type
+BROKEN_powerpc64= fails to compile: ksw.c: error: emmintrin.h: No such file or directory
USES= perl5 shebangfix tar:bzip2
SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
diff --git a/biology/gmap/Makefile b/biology/gmap/Makefile
index af0f1e6e6eba..070ce4c38210 100644
--- a/biology/gmap/Makefile
+++ b/biology/gmap/Makefile
@@ -27,7 +27,7 @@ SIMD_CONFIGURE_OFF= --disable-builtin-popcount --disable-simd
BROKEN_aarch64= Does not build: invokes x86 asm
BROKEN_armv6= Does not build: invokes x86 asm
BROKEN_mips64= Does not build: invokes x86 asm
-BROKEN_powerpc64= Does not build on powerpc64
+BROKEN_powerpc64= Does not build: invokes x86 asm
BROKEN_sparc64= Does not build: invokes x86 asm
# shebang_fix operates during patch.
diff --git a/biology/iolib/Makefile b/biology/iolib/Makefile
index 5c5eb97ab207..388c3b365862 100644
--- a/biology/iolib/Makefile
+++ b/biology/iolib/Makefile
@@ -13,6 +13,8 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcurl.so:ftp/curl
+BROKEN_powerpc64= fails to compile: bgzip.c: error: invalid operands to binary &
+
USE_GITHUB= yes
GH_ACCOUNT= jkbonfield
diff --git a/biology/plinkseq/Makefile b/biology/plinkseq/Makefile
index 05a8a59792ce..68ca7236bd59 100644
--- a/biology/plinkseq/Makefile
+++ b/biology/plinkseq/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
BROKEN_aarch64= Does not build: Host architecture was not detected as supported by protobuf
BROKEN_mips64= Does not build: Host architecture was not detected as supported by protobuf
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: atomicops.h: error: stray '\#' in program
USES= libtool gmake