aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2020-08-30 16:14:22 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2020-08-30 16:14:22 +0000
commitbc66849a977caf6418430ffb620bad9220f1f3b8 (patch)
tree0b76510d128c4048756909e273a636f63219ca43 /biology
parentcd5419ba06293da4d726656d6a94ce7e31f6ea8b (diff)
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/diamond/Makefile2
-rw-r--r--biology/diamond/distinfo6
-rw-r--r--biology/diamond/files/patch-src_util_system_system.cpp45
3 files changed, 4 insertions, 49 deletions
diff --git a/biology/diamond/Makefile b/biology/diamond/Makefile
index 3fc27f9522a0..8308a7e5b666 100644
--- a/biology/diamond/Makefile
+++ b/biology/diamond/Makefile
@@ -2,7 +2,7 @@
PORTNAME= diamond
DISTVERSIONPREFIX= v
-DISTVERSION= 2.0.2
+DISTVERSION= 2.0.4
CATEGORIES= biology
MAINTAINER= jrm@FreeBSD.org
diff --git a/biology/diamond/distinfo b/biology/diamond/distinfo
index 57ee2d88290d..78782c2c7fde 100644
--- a/biology/diamond/distinfo
+++ b/biology/diamond/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1596712682
-SHA256 (bbuchfink-diamond-v2.0.2_GH0.tar.gz) = fd22c2a1960cc1b4d02b66f87c66624c6e495de3128b73da70171fc134a508b5
-SIZE (bbuchfink-diamond-v2.0.2_GH0.tar.gz) = 1117286
+TIMESTAMP = 1598800137
+SHA256 (bbuchfink-diamond-v2.0.4_GH0.tar.gz) = 94e8fe72bdc28b83fd0f2d90c439b58b63b38263aa1a3905582ef68f614ae95d
+SIZE (bbuchfink-diamond-v2.0.4_GH0.tar.gz) = 1120470
diff --git a/biology/diamond/files/patch-src_util_system_system.cpp b/biology/diamond/files/patch-src_util_system_system.cpp
deleted file mode 100644
index 5e84a9496238..000000000000
--- a/biology/diamond/files/patch-src_util_system_system.cpp
+++ /dev/null
@@ -1,45 +0,0 @@
---- src/util/system/system.cpp.orig 2020-08-05 17:04:09 UTC
-+++ src/util/system/system.cpp
-@@ -6,14 +6,19 @@
- #include "../log_stream.h"
-
- #ifdef _MSC_VER
--#include <windows.h>
-+ #include <windows.h>
- #else
--#include <unistd.h>
--#include <sys/stat.h>
--#ifndef __APPLE__
--#include <sys/sysinfo.h>
-+ #include <unistd.h>
-+ #include <sys/stat.h>
-+ #ifndef __APPLE__
-+ #ifdef __FreeBSD__
-+ #include <sys/types.h>
-+ #include <sys/sysctl.h>
-+ #else
-+ #include <sys/sysinfo.h>
-+ #endif
-+ #endif
- #endif
--#endif
-
- using std::string;
- using std::cout;
-@@ -129,6 +134,16 @@ void reset_color(bool err) {
- double total_ram() {
- #if defined(WIN32) || defined(__APPLE__)
- return 0.0;
-+#elif defined(__FreeBSD__)
-+ int mib[2] = { CTL_HW, HW_REALMEM };
-+ u_int namelen = sizeof(mib) / sizeof(mib[0]);
-+ uint64_t oldp;
-+ size_t oldlenp = sizeof(oldp);
-+
-+ if (sysctl(mib, namelen, &oldp, &oldlenp, NULL, 0) < 0)
-+ return 0.0;
-+ else
-+ return oldp / 1e9;
- #else
- struct sysinfo info;
- if (sysinfo(&info) != 0)