aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-07-24 07:08:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-07-24 07:08:11 +0000
commitc0f387431ad322b6b001de8539d03dd91c257dce (patch)
tree117739f8f418f0e3747d262e007735e7bdc95b3d /biology
parent8ed0c4eaebb973269936529ba54cbffae7db9313 (diff)
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/rubygem-bio-shell/Makefile26
-rw-r--r--biology/rubygem-bio-shell/distinfo3
-rw-r--r--biology/rubygem-bio-shell/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 51d38daecc7f..12546e838c16 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -150,6 +150,7 @@
SUBDIR += rubygem-bio
SUBDIR += rubygem-bio-executables
SUBDIR += rubygem-bio-old-biofetch-emulator
+ SUBDIR += rubygem-bio-shell
SUBDIR += samtools
SUBDIR += scrm
SUBDIR += seaview
diff --git a/biology/rubygem-bio-shell/Makefile b/biology/rubygem-bio-shell/Makefile
new file mode 100644
index 000000000000..ab2b01b3eb1a
--- /dev/null
+++ b/biology/rubygem-bio-shell/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bio-shell
+PORTVERSION= 1.0.0
+CATEGORIES= biology rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Command-line interface on BioRuby
+
+LICENSE= BSD2CLAUSE RUBY
+LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
+LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= rubygem-bio>=2.0.0:biology/rubygem-bio
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/bioruby
+
+.include <bsd.port.mk>
diff --git a/biology/rubygem-bio-shell/distinfo b/biology/rubygem-bio-shell/distinfo
new file mode 100644
index 000000000000..5f8a5cec4504
--- /dev/null
+++ b/biology/rubygem-bio-shell/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595416511
+SHA256 (rubygem/bio-shell-1.0.0.gem) = 5a41c4226c12de49476bda8e59dd17ac3340b15cebc2f241842334d9de822528
+SIZE (rubygem/bio-shell-1.0.0.gem) = 46592
diff --git a/biology/rubygem-bio-shell/pkg-descr b/biology/rubygem-bio-shell/pkg-descr
new file mode 100644
index 000000000000..29237e3aa454
--- /dev/null
+++ b/biology/rubygem-bio-shell/pkg-descr
@@ -0,0 +1,8 @@
+bio-shell, providing BioRuby Shell, is a command-line interface for BioRuby, an
+open source bioinformatics library for Ruby.
+
+This code has historically been part of the BioRuby gem, but has been split into
+its own gem as part of an effort to modularize BioRuby. bio-shell and many more
+plugins are available at biogems.info.
+
+WWW: https://github.com/bioruby/bioruby-shell