aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-03-21 15:10:17 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-03-21 15:10:17 +0000
commitf28acb9dcb1134e9eed638ce0a5f971d012d9a1d (patch)
tree661c917e6975fc77bb9018d325c606ce6371d2c9 /biology
parent05af9de3b9969b207dcec2f0bab36174f8ede75b (diff)
downloadports-f28acb9dcb1134e9eed638ce0a5f971d012d9a1d.tar.gz
ports-f28acb9dcb1134e9eed638ce0a5f971d012d9a1d.zip
biology/biolibc: Low-level high-performance bioinformatics library
Biolibc is a library of fast, memory-efficient, low-level functions for processing biological data. Like libc, it consists of numerous disparate, general-purpose functions which could be used by a wide variety of applications. These include functions for streaming common file formats such as SAM and VCF, string functions specific to bioinformatics, etc.
Notes
Notes: svn path=/head/; revision=568921
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/biolibc/Makefile16
-rw-r--r--biology/biolibc/distinfo3
-rw-r--r--biology/biolibc/pkg-descr7
-rw-r--r--biology/biolibc/pkg-plist6
5 files changed, 33 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 0143926f385f..294c24aa9c6e 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -12,6 +12,7 @@
SUBDIR += bedtools
SUBDIR += bioawk
SUBDIR += biococoa
+ SUBDIR += biolibc
SUBDIR += bioparser
SUBDIR += biosoup
SUBDIR += bolt-lmm
diff --git a/biology/biolibc/Makefile b/biology/biolibc/Makefile
new file mode 100644
index 000000000000..c1f3108fcd4c
--- /dev/null
+++ b/biology/biolibc/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= biolibc
+DISTVERSION= 0.1.1
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Low-level high-performance bioinformatics library
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= auerlab
+
+.include <bsd.port.mk>
diff --git a/biology/biolibc/distinfo b/biology/biolibc/distinfo
new file mode 100644
index 000000000000..353580791bed
--- /dev/null
+++ b/biology/biolibc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1616330997
+SHA256 (auerlab-biolibc-0.1.1_GH0.tar.gz) = 0b4a5a63a17998423a583e05e6244369b0c7195c09d2c1c25f1bcde45d7d6388
+SIZE (auerlab-biolibc-0.1.1_GH0.tar.gz) = 11770
diff --git a/biology/biolibc/pkg-descr b/biology/biolibc/pkg-descr
new file mode 100644
index 000000000000..498258899832
--- /dev/null
+++ b/biology/biolibc/pkg-descr
@@ -0,0 +1,7 @@
+Biolibc is a library of fast, memory-efficient, low-level functions for
+processing biological data. Like libc, it consists of numerous disparate,
+general-purpose functions which could be used by a wide variety of
+applications. These include functions for streaming common file formats such
+as SAM and VCF, string functions specific to bioinformatics, etc.
+
+WWW: https://github.com/auerlab/vcfio
diff --git a/biology/biolibc/pkg-plist b/biology/biolibc/pkg-plist
new file mode 100644
index 000000000000..ce0fa3da78f3
--- /dev/null
+++ b/biology/biolibc/pkg-plist
@@ -0,0 +1,6 @@
+include/biostring.h
+include/dsvio.h
+include/samio.h
+include/vcfio.h
+lib/libbiolibc.a
+man/man1/biolibc.1.gz