aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-03-16 06:57:14 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-03-16 06:57:14 +0000
commitf53fc71c73ae49eb679b9813efcb19c9fcbf4e8c (patch)
tree62da0344c6e9d54dc8c99e1714288dca635ae223 /biology
parenta383ea7000853ab9a79f4a7f7441a27b6ec9ae71 (diff)
downloadports-f53fc71c73ae49eb679b9813efcb19c9fcbf4e8c.tar.gz
ports-f53fc71c73ae49eb679b9813efcb19c9fcbf4e8c.zip
Notes
Diffstat (limited to 'biology')
-rw-r--r--biology/povchem/Makefile34
-rw-r--r--biology/povchem/distinfo3
-rw-r--r--biology/povchem/files/patch-ab20
-rw-r--r--biology/povchem/files/patch-ac11
-rw-r--r--biology/povchem/pkg-comment1
-rw-r--r--biology/povchem/pkg-descr6
-rw-r--r--biology/povchem/pkg-plist3
7 files changed, 78 insertions, 0 deletions
diff --git a/biology/povchem/Makefile b/biology/povchem/Makefile
new file mode 100644
index 000000000000..030556d5836e
--- /dev/null
+++ b/biology/povchem/Makefile
@@ -0,0 +1,34 @@
+# New ports collection Makefile for: povchem
+# Version required: 1.0
+# Date created: Mar 14 1998
+# Whom: frankch@waru.life.nthu.edu.tw
+#
+# $Id$
+#
+
+DISTNAME= povchem-1.0
+CATEGORIES= biology graphics
+MASTER_SITES= http://cherubino.med.jhmi.edu/~paul/PC_Dist/v1.00/
+DISTFILES= povchem.c \
+ povchem.cfg \
+ periodic.tab
+
+MAINTAINER= frankch@waru.life.nthu.edu.tw
+
+NO_WRKSUBDIR= yes
+
+pre-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/povchem.c ${WRKSRC}
+ @${CP} ${DISTDIR}/povchem.cfg ${WRKSRC}
+ @${CP} ${DISTDIR}/periodic.tab ${WRKSRC}
+
+do-extract:
+ @${TOUCH} ${TOUCH_FLAGS} ${EXTRACT_COOKIE}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/povchem ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/povchem.cfg ${PREFIX}/etc
+ @${INSTALL_DATA} ${WRKSRC}/periodic.tab ${PREFIX}/share
+
+.include <bsd.port.mk>
diff --git a/biology/povchem/distinfo b/biology/povchem/distinfo
new file mode 100644
index 000000000000..e2e088fc8dcf
--- /dev/null
+++ b/biology/povchem/distinfo
@@ -0,0 +1,3 @@
+MD5 (povchem.c) = a8eceada2acdee9f69e018a49033dfc4
+MD5 (povchem.cfg) = 23c6417b12d9562c68e1242b7e339138
+MD5 (periodic.tab) = bdb231f0c8b6e1e37c3b3b025d73a7b0
diff --git a/biology/povchem/files/patch-ab b/biology/povchem/files/patch-ab
new file mode 100644
index 000000000000..222f2bfb9fee
--- /dev/null
+++ b/biology/povchem/files/patch-ab
@@ -0,0 +1,20 @@
+--- povchem.c.orig Sat Mar 14 17:19:41 1998
++++ povchem.c Sat Mar 14 17:20:32 1998
+@@ -482,7 +482,7 @@
+ */
+
+ if (*fileName==NULL) {
+- New_String(fileName,"povchem.cfg");
++ New_String(fileName,"/usr/local/etc/povchem.cfg");
+ if ((config=fopen(*fileName,"r"))==NULL) {
+ puts("Can't read the configuration file \"povchem.cfg\"!");
+ perror("Reason");
+@@ -731,7 +731,7 @@
+
+ no_config:
+
+- if (!PERIODIC_TABLE_FILE) New_String(&PERIODIC_TABLE_FILE,"periodic.tab");
++ if (!PERIODIC_TABLE_FILE) New_String(&PERIODIC_TABLE_FILE,"/usr/local/share/periodic.tab");
+ if (!FINISH) New_String(&FINISH,"Plastic");
+ if (!FINISH_DECLARATION) New_String(&FINISH_DECLARATION,"\
+ finish {\n\
diff --git a/biology/povchem/files/patch-ac b/biology/povchem/files/patch-ac
new file mode 100644
index 000000000000..bf45153e7732
--- /dev/null
+++ b/biology/povchem/files/patch-ac
@@ -0,0 +1,11 @@
+--- povchem.cfg.orig Sun Mar 15 14:14:16 1998
++++ povchem.cfg Sun Mar 15 14:15:13 1998
+@@ -331,7 +331,7 @@
+ # the type of image POV-Ray generates - usually TGA (also called TARGA).
+ #
+ #Viewer = c:\util\dvpeg.exe
+-Viewer = /usr/local/bin/xv
++Viewer = /usr/X11R6/bin/xv
+
+ # If ColorSplit is Proportional, 'Power' determines the power of the vdW radii
+ # to which the point of color change is proportional. See the manual for
diff --git a/biology/povchem/pkg-comment b/biology/povchem/pkg-comment
new file mode 100644
index 000000000000..c0d5024801f5
--- /dev/null
+++ b/biology/povchem/pkg-comment
@@ -0,0 +1 @@
+Simple yet powerful tool to generate POV from a PDB file
diff --git a/biology/povchem/pkg-descr b/biology/povchem/pkg-descr
new file mode 100644
index 000000000000..0edf525c2059
--- /dev/null
+++ b/biology/povchem/pkg-descr
@@ -0,0 +1,6 @@
+PovChem is a powerful tool to generate a POV format file from a PDB entry.
+It supports CPK, Ball-n-Stick and Cylinder model. You could adjust a lot
+of parameters to get a good molecuar graphic.
+
+The document could be found at
+ http://cherubino.med.jhmi.edu/~paul/Manual.html
diff --git a/biology/povchem/pkg-plist b/biology/povchem/pkg-plist
new file mode 100644
index 000000000000..85c28b24592a
--- /dev/null
+++ b/biology/povchem/pkg-plist
@@ -0,0 +1,3 @@
+bin/povchem
+etc/povchem.cfg
+share/periodic.tab