aboutsummaryrefslogtreecommitdiff
path: root/comms/fldigi/Makefile
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2019-04-19 08:36:44 +0000
committerStephen Hurd <shurd@FreeBSD.org>2019-04-19 08:36:44 +0000
commite7e64a505eff4d5f4e0d5505e5704058a3683154 (patch)
treef585644ed86dec2de29d60df759ef6295c3a800f /comms/fldigi/Makefile
parentf4f3b6d73e386c47666d75037edcfd67e41a863e (diff)
downloadports-e7e64a505eff4d5f4e0d5505e5704058a3683154.tar.gz
ports-e7e64a505eff4d5f4e0d5505e5704058a3683154.zip
Update to 4.1.02
Remove SNDFILE and PORTAUDIO options. These are required now. Show devices in the form of /dev/dspX not /dev/dspX.Y in config.
Notes
Notes: svn path=/head/; revision=499334
Diffstat (limited to 'comms/fldigi/Makefile')
-rw-r--r--comms/fldigi/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index 96ebf0991582..c9b16c24c070 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= fldigi
-PORTVERSION= 4.1.01
-PORTREVISION= 1
+PORTVERSION= 4.1.02
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -30,13 +29,11 @@ USE_XORG= x11 xft xext xfixes xcursor xinerama xrender
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config" \
EXTRA_LIBS="-lexecinfo"
-OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS SNDFILE PORTAUDIO PULSEAUDIO HAMLIB NLS DOCS
+OPTIONS_DEFINE= NATIVE_OPT FLARQ OSS PULSEAUDIO HAMLIB NLS DOCS
NATIVE_OPT_DESC= Enable Native Optimizations
FLARQ_DESC= Compile flarq
OSS_DESC= Support OSS
-SNDFILE_DESC= Support for libsndfile
-PORTAUDIO_DESC= PortAudio support
PULSEAUDIO_DESC= PulseAudio support
HAMLIB_DESC= Support rig control via hamlib
@@ -47,22 +44,17 @@ NATIVE_OPT_CONFIGURE_ON= --enable-optimizations=native
NATIVE_OPT_CONFIGURE_OFF= --enable-optimizations=none
FLARQ_CONFIGURE_ENABLE= flarq
OSS_CONFIGURE_ENABLE= oss
-SNDFILE_CONFIGURE_ENABLE= sndfile
-SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
-PORTAUDIO_CONFIGURE_ENABLE= portaudio
-PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
-PULSEAUDIO_CONFIGURE_ENABLE= pulseaudio
+PULSEAUDIO_CONFIGURE_WITH= pulseaudio
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-HAMLIB_CONFIGURE_ENABLE= hamlib
+HAMLIB_CONFIGURE_WITH= hamlib
HAMLIB_LIB_DEPENDS= libhamlib.so:comms/hamlib
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
# Always need asciidoc for man pages
CONFIGURE_ARGS+=--with-asciidoc
-# Upstream as of 4.0.5 always uses portaudio and sndfile now
-# Which makes fldigi configure options portaudio & oss useless
-CONFIGURE_ARGS+=--with-portaudio --disable-oss
+# Always need soundfile
+CONFIGURE_ARGS+=--with-sndfile
post-configure:
# force rebuild of man pages