aboutsummaryrefslogtreecommitdiff
path: root/comms/lirc
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-11 13:59:47 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-11 13:59:47 +0000
commit49108186e8717109f9bc3dba3a46a4beed6a77bf (patch)
tree2015e43bc8319ab8afc24049da6744399385736d /comms/lirc
parent2355fc72994bc0fd7169c263304460a979189e00 (diff)
downloadports-49108186e8717109f9bc3dba3a46a4beed6a77bf.tar.gz
ports-49108186e8717109f9bc3dba3a46a4beed6a77bf.zip
comms/lirc:
- Fix missing -lusb [1] - Convert to USES=libtool and bump dependent ports - Add INSTALL_TARGET=install-strip - Use @sample Reported by: sbruno [1]
Notes
Notes: svn path=/head/; revision=364613
Diffstat (limited to 'comms/lirc')
-rw-r--r--comms/lirc/Makefile27
-rw-r--r--comms/lirc/pkg-plist8
2 files changed, 17 insertions, 18 deletions
diff --git a/comms/lirc/Makefile b/comms/lirc/Makefile
index 7cc6381240d1..6e5d9b4d535c 100644
--- a/comms/lirc/Makefile
+++ b/comms/lirc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lirc
PORTVERSION= 0.9.0
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= SF/${PORTNAME}/LIRC/${PORTVERSION}
@@ -14,19 +14,19 @@ COMMENT= Linux Infrared Remote Control
BUILD_DEPENDS= v4l_compat>=1.0.20110603:${PORTSDIR}/multimedia/v4l_compat
-USE_AUTOTOOLS= libtool automake autoheader aclocal autoconf
-USES= gmake tar:bzip2
-ACLOCAL_ARGS= -I "${ACLOCAL_DIR}" -I ${LOCALBASE}/share/aclocal
+INSTALL_TARGET= install-strip
+USES= gmake libtool tar:bzip2
+USE_AUTOTOOLS= libtoolize automake autoheader aclocal autoconf
+AUTOMAKE_ARGS= -a -c -f
USE_XORG= sm x11
USE_PYTHON= yes
USE_CSTD= gnu89
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
- --sysconfdir=${PREFIX}/etc
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
+ --sysconfdir=${PREFIX}/etc
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC DOCS EXAMPLES
@@ -63,10 +63,11 @@ CONFIGURE_ARGS+= --enable-debug
RUN_DEPENDS+= uartlirc>=0.3:${PORTSDIR}/comms/uartlirc
.endif
-# XXX: work around an issue with automake-1.13 erroring out on a
-# non-existent m4 directory before libtoolize creates it
-pre-configure::
- @${MKDIR} ${WRKSRC}/m4
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's/`$${LIBUSB_CONFIG} --libs`/-lusb/' \
+ -e 's/`$${LIBUSB_CONFIG} --cflags`//' \
+ ${WRKSRC}/configure.ac
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/comms/lirc/pkg-plist b/comms/lirc/pkg-plist
index ae72a95243b0..ca8293461299 100644
--- a/comms/lirc/pkg-plist
+++ b/comms/lirc/pkg-plist
@@ -12,9 +12,9 @@ bin/pronto2lirc
bin/xmode2
include/lirc/lirc_client.h
lib/liblirc_client.a
-lib/liblirc_client.la
lib/liblirc_client.so
-lib/liblirc_client.so.2
+lib/liblirc_client.so.0
+lib/liblirc_client.so.0.2.1
man/man1/ircat.1.gz
man/man1/irexec.1.gz
man/man1/irpty.1.gz
@@ -31,8 +31,6 @@ man/man8/lircmd.8.gz
sbin/lircd
sbin/lircmd
@dirrm include/lirc
-@unexec if cmp -s %D/etc/lircd.conf.sample %D/etc/lircd.conf; then rm -f %D/etc/lircd.conf; fi
-etc/lircd.conf.sample
-@exec if [ ! -f %D/etc/lircd.conf ] ; then cp -p %D/%F %B/lircd.conf; fi
+@sample etc/lircd.conf.sample
@exec mkdir -p /var/run/lirc
@unexec rmdir /var/run/lirc 2> /dev/null || true