aboutsummaryrefslogtreecommitdiff
path: root/comms/nanovna-saver/files/patch-setup.py
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-01-01 23:14:43 +0000
committerDiane Bruce <db@FreeBSD.org>2020-01-01 23:14:43 +0000
commitc24e86c24c064b18aff0a1360efa76ce1b67710f (patch)
treefdcc43f9b837ba4f68ad7859e2f9bb7c4e177c19 /comms/nanovna-saver/files/patch-setup.py
parent5f582b73ab228c78efcb60ec79e46d7de3bdeea7 (diff)
downloadports-c24e86c24c064b18aff0a1360efa76ce1b67710f.tar.gz
ports-c24e86c24c064b18aff0a1360efa76ce1b67710f.zip
NanoVNASaver
A multiplatform tool to save Touchstone files from the NanoVNA, sweep frequency spans in segments to gain more than 101 data points, and generally display and analyze the resulting data.
Notes
Notes: svn path=/head/; revision=521787
Diffstat (limited to 'comms/nanovna-saver/files/patch-setup.py')
-rw-r--r--comms/nanovna-saver/files/patch-setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/comms/nanovna-saver/files/patch-setup.py b/comms/nanovna-saver/files/patch-setup.py
new file mode 100644
index 000000000000..04306045bbad
--- /dev/null
+++ b/comms/nanovna-saver/files/patch-setup.py
@@ -0,0 +1,36 @@
+--- setup.py.orig 2019-12-04 11:05:36 UTC
++++ setup.py
+@@ -15,10 +15,11 @@
+ # along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+ import sys
++import io
+ from NanoVNASaver.about import version
+
+-if sys.version_info < (3, 7):
+- print("You need at least Python 3.7 for this application!")
++if sys.version_info < (3, 3):
++ print("You need at least Python 3.3 for this application!")
+ if sys.version_info[0] < 3:
+ print("try running with python3 {}".format(" ".join(sys.argv)))
+ sys.exit(1)
+@@ -30,7 +31,7 @@ except ImportError:
+ print("Try installing them with pip install setuptools")
+ sys.exit(1)
+
+-with open("README.md", "r") as fh:
++with io.open("README.md", "r", encoding="utf-8") as fh:
+ long_description = fh.read()
+
+ setup(
+@@ -48,10 +49,4 @@ setup(
+ 'NanoVNASaver = NanoVNASaver.__main__:main'
+ ],
+ },
+- install_requires=[
+- 'pyserial',
+- 'PyQt5',
+- 'numpy',
+- 'scipy'
+- ],
+ )