aboutsummaryrefslogtreecommitdiff
path: root/comms/yaps/files/patch-Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-11-18 00:37:15 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-11-18 00:37:15 +0000
commit57e3213639e451ddc7e2311587929b679827e385 (patch)
tree2b38c4ddded75d6142be0d45209292474f0596a8 /comms/yaps/files/patch-Makefile
parentec67c2b687d0b609821be9dac725661545f90926 (diff)
downloadports-57e3213639e451ddc7e2311587929b679827e385.tar.gz
ports-57e3213639e451ddc7e2311587929b679827e385.zip
Notes
Diffstat (limited to 'comms/yaps/files/patch-Makefile')
-rw-r--r--comms/yaps/files/patch-Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/comms/yaps/files/patch-Makefile b/comms/yaps/files/patch-Makefile
new file mode 100644
index 000000000000..58eb808e59ec
--- /dev/null
+++ b/comms/yaps/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2013-11-17 23:01:50.000000000 +0800
++++ Makefile 2013-11-17 23:04:00.000000000 +0800
+@@ -33,15 +33,15 @@ yaps.doc: yaps.html
+ lynx -cfg=/dev/null -nolist -dump $< > $@
+
+ install: $(DSTFLE) $(CFGFILE)
+- if [ ! -d $(YAPS_LIBDIR) ]; then \
+- install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(YAPS_LIBDIR) ; \
++ if [ ! -d $(DESTDIR)$(YAPS_LIBDIR) ]; then \
++ install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(DESTDIR)$(YAPS_LIBDIR) ; \
+ fi
+ @if [ -f contrib/Makefile ]; then \
+ $(MAKE) -C contrib install ; \
+ fi
+
+ $(DSTFLE): yaps
+- install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $@
++ install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $(DESTDIR)$@
+
+ $(CFGFILE): yaps.rc
+ @if [ ! -f $@ ]; then \