aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-06 00:22:59 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-06 00:22:59 +0000
commit5e64423294df7035013d7417ecf5a2a6b7e4c050 (patch)
tree8ec88015045099d52722ad3cb42ddd3238e5a764 /converters
parent869c414e67dbe60673b64023602555ecc72aa7b1 (diff)
downloadports-5e64423294df7035013d7417ecf5a2a6b7e4c050.tar.gz
ports-5e64423294df7035013d7417ecf5a2a6b7e4c050.zip
converters/wkhtmltopdf: fix build on GCC architectures
Both GCC 4.2 and 9 can't build this port, but 8 can, so add GCC architectures to the conditional.
Notes
Notes: svn path=/head/; revision=560456
Diffstat (limited to 'converters')
-rw-r--r--converters/wkhtmltopdf/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index 88aa1f123b87..cc72538d8b22 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png
-USES= gmake iconv jpeg perl5 pkgconfig ssl xorg
+USES= compiler gmake iconv jpeg perl5 pkgconfig ssl xorg
USE_XORG= x11 xext xrender
USE_PERL5= build
USE_LDCONFIG= yes
@@ -56,7 +56,7 @@ MAKE_ARGS= INSTALL_ROOT="${STAGEDIR}${PREFIX}"
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
+.if ${ARCH} == "i386" || ${CHOSEN_COMPILER_TYPE} == gcc
USE_GCC= 8
.endif