aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql12-contrib
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-08-17 16:56:18 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-08-17 16:56:18 +0000
commit117e1e7b9495b3b439c5f016a8afd6f347393a8c (patch)
tree8cee06cade7368b521192a9ad083ea45c8973274 /databases/postgresql12-contrib
parent6f387eb66bed25ee6ab620193a0cef5606636678 (diff)
downloadports-117e1e7b9495b3b439c5f016a8afd6f347393a8c.tar.gz
ports-117e1e7b9495b3b439c5f016a8afd6f347393a8c.zip
Add an XML option to postgresql12-contrib
Avoids libxml2/libxslt for systems that don't need XML support. Although there was substantial interest in the PR to backport to 10, I've only done pgsql12 for now, as I don't want to interfere with the effort to make pgsql11 the default. If things work well here, it can be backported to earlier versions as well. PR: 239638 Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=509159
Diffstat (limited to 'databases/postgresql12-contrib')
-rw-r--r--databases/postgresql12-contrib/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/databases/postgresql12-contrib/Makefile b/databases/postgresql12-contrib/Makefile
index 1c8dc612d65a..f7c88aa12cd4 100644
--- a/databases/postgresql12-contrib/Makefile
+++ b/databases/postgresql12-contrib/Makefile
@@ -8,9 +8,6 @@ CATEGORIES= databases
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
-LIB_DEPENDS= libxslt.so:textproc/libxslt \
- libxml2.so:textproc/libxml2
-
MASTERDIR= ${.CURDIR}/../postgresql12-server
USES= bison pgsql:12
@@ -20,17 +17,21 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
-CONFIGURE_ARGS= --with-libxslt --with-libxml --disable-nls --with-uuid=bsd
+CONFIGURE_ARGS= --disable-nls --with-uuid=bsd
LDFLAGS+= -lpthread -L${PREFIX}/lib
-OPTIONS_DEFINE= DOCS OPENSSL
-OPTIONS_DEFAULT=OPENSSL
+OPTIONS_DEFINE= DOCS OPENSSL XML
+OPTIONS_DEFAULT=OPENSSL XML
OPTIONS_SUB= yes
OPENSSL_DESC= Build with OpenSSL support
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= openssl
+XML_CONFIGURE_WITH= libxslt libxml
+XML_LIB_DEPENDS=libxslt.so:textproc/libxslt \
+ libxml2.so:textproc/libxml2
+
post-configure:
@cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks