aboutsummaryrefslogtreecommitdiff
path: root/deskutils/spice-gtk/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2015-02-09 16:21:59 +0000
committerJason Helfman <jgh@FreeBSD.org>2015-02-09 16:21:59 +0000
commit1f225e555cb77a1e9b9e23f824dd77a71a004d40 (patch)
tree1c247e62f548ab7b5f6c1d714670165ae9e570d6 /deskutils/spice-gtk/Makefile
parentbeb4e272158f74067a0e238411e2871ba0e8f87f (diff)
downloadports-1f225e555cb77a1e9b9e23f824dd77a71a004d40.tar.gz
ports-1f225e555cb77a1e9b9e23f824dd77a71a004d40.zip
Add new ports: spice-gtk and py-spice-gtk
spice-gtk is a GTK+2 and GTK+3 SPICE widget. It features glib-based objects for SPICE protocol parsing and a gtk widget for embedding the SPICE display into other applications such as virt-manager. Python bindings are available too. WWW: http://www.spice-space.org/ PR: 196949 (based on) Submitted by: olevole@olevole.ru
Notes
Notes: svn path=/head/; revision=378739
Diffstat (limited to 'deskutils/spice-gtk/Makefile')
-rw-r--r--deskutils/spice-gtk/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
new file mode 100644
index 000000000000..76389d71d01e
--- /dev/null
+++ b/deskutils/spice-gtk/Makefile
@@ -0,0 +1,64 @@
+# Created by: olevole@olevole.ru
+# $FreeBSD$
+
+PORTNAME= spice-gtk
+PORTVERSION= 0.26
+CATEGORIES?= deskutils gnome
+MASTER_SITES= http://www.spice-space.org/download/gtk/
+
+MAINTAINER= olevole@olevole.ru
+COMMENT?= Gtk client and libraries for SPICE remote desktop servers
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+
+USE_XORG= pixman
+USE_GNOME= gnomeprefix gtk20 gtk30 intltool introspection:build
+USES= gmake libtool pkgconfig tar:bzip2 pathfix
+
+.if defined(SPICE_SLAVE)
+CATEGORIES+= python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
+CONFIGURE_ARGS+= --with-python
+PLIST_FILES+= %%PYTHON_SITELIBDIR%%/SpiceClientGtk.a \
+ %%PYTHON_SITELIBDIR%%/SpiceClientGtk.so
+USES+= python
+.endif
+
+CONFIGURE_ENV+= SSL_CFLAGS=-I${OPENSSLINC} \
+ SSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= NLS DOCS SASL
+OPTIONS_DEFAULT= GSTREAMER SASL
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+OPTIONS_SINGLE= AUDIO
+OPTIONS_SINGLE_AUDIO= GSTREAMER PULSEAUDIO NOAUDIO
+
+NOAUDIO_DESC= Disable audio backend
+
+GSTREAMER_CONFIGURE_ON= --with-audio=gstreamer
+GSTREAMER_USE= gstreamer=yes
+PULSEAUDIO_CONFIGURE_ON= --with-audio=pulse
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CONFIGURE_ENABLE= pulse
+NOAUDIO_CONFIGURE_ON= --with-audio=no
+SASL_CONFIGURE_WITH= sasl=yes
+SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+
+.include <bsd.port.mk>