aboutsummaryrefslogtreecommitdiff
path: root/devel/codeworker/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-31 03:14:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-31 03:14:57 +0000
commit25dc373b47363b8e74bac8e82078fe31d0684a57 (patch)
tree4957466678021974184be19b9837e04aa1852be2 /devel/codeworker/Makefile
parent97142dd1eb63a5faed0a3c7f001f3aa20cb71ce2 (diff)
downloadports-25dc373b47363b8e74bac8e82078fe31d0684a57.tar.gz
ports-25dc373b47363b8e74bac8e82078fe31d0684a57.zip
Notes
Diffstat (limited to 'devel/codeworker/Makefile')
-rw-r--r--devel/codeworker/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/codeworker/Makefile b/devel/codeworker/Makefile
new file mode 100644
index 000000000000..165ac529163a
--- /dev/null
+++ b/devel/codeworker/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: CodeWorker
+# Date created: Dec 31, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= codeworker
+PORTVERSION= 3.2
+CATEGORIES= devel
+MASTER_SITES= http://codeworker.free.fr/downloads/
+DISTNAME= CodeWorker_SRC${PORTVERSION:S/./_/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A parsing tool and a source code generator
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+LDFLAGS+= -lcompat
+USE_GMAKE= yes
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CXXFLAGS|#CXXFLAGS|g" \
+ -e s"|LFLAGS|LDFLAGS|" -e "s|^LDFLAGS|#LDFLAGS|" \
+ -e "s|CC|CXX|g" -e "s|^CXX|#CXX|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/CodeWorker ${PREFIX}/bin
+
+.include <bsd.port.mk>