aboutsummaryrefslogtreecommitdiff
path: root/devel/global
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>2000-06-28 01:04:13 +0000
committerChuck Robey <chuckr@FreeBSD.org>2000-06-28 01:04:13 +0000
commita6e096ead8d963903cef4a8caf99d45b3150312a (patch)
tree03c53ec28c6379ec4939081406dcfc3c515fdea1 /devel/global
parent1949444b57c1180c592ed005eda9ddfe92664c1c (diff)
downloadports-a6e096ead8d963903cef4a8caf99d45b3150312a.tar.gz
ports-a6e096ead8d963903cef4a8caf99d45b3150312a.zip
Notes
Diffstat (limited to 'devel/global')
-rw-r--r--devel/global/Makefile20
-rw-r--r--devel/global/distinfo1
-rw-r--r--devel/global/pkg-comment1
-rw-r--r--devel/global/pkg-descr5
-rw-r--r--devel/global/pkg-plist5
5 files changed, 32 insertions, 0 deletions
diff --git a/devel/global/Makefile b/devel/global/Makefile
new file mode 100644
index 000000000000..85c65ff56751
--- /dev/null
+++ b/devel/global/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: global
+# Date created: 20 June 2000
+# Whom: chuckr@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= global
+PORTVERSION= 3.55
+CATEGORIES= devel
+MASTER_SITES= http://www.tamacom.com/unix/
+
+MAINTAINER= chuckr@freebsd.org
+
+MAKE_FLAGS+= INCDIR=$(LOCALBASE)/include LIBDIR=$(LOCALBASE)/lib BINDIR=$(LOCALBASE)/bin SHAREDIR=$(LOCALBASE)
+
+MAN1= htags.1 btreeop.1 gtags.1 global.1 gctags.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/devel/global/distinfo b/devel/global/distinfo
new file mode 100644
index 000000000000..ed6cc8fc019a
--- /dev/null
+++ b/devel/global/distinfo
@@ -0,0 +1 @@
+MD5 (global-3.55.tar.gz) = 7d70e8543f50be33172239fe69958c49
diff --git a/devel/global/pkg-comment b/devel/global/pkg-comment
new file mode 100644
index 000000000000..43e122d1b114
--- /dev/null
+++ b/devel/global/pkg-comment
@@ -0,0 +1 @@
+GLOBAL is a source code tag system
diff --git a/devel/global/pkg-descr b/devel/global/pkg-descr
new file mode 100644
index 000000000000..994e0edda306
--- /dev/null
+++ b/devel/global/pkg-descr
@@ -0,0 +1,5 @@
+GLOBAL is a source code tag system that works the same way across diverse
+environments. Supported languages are C/Yacc and Java.
+You can locate a specified function in the source files and move there easily.
+It is useful for hacking a large project containing many subdirectories,
+many '#ifdef' and many main() functions, like MH, X or BSD kernel.
diff --git a/devel/global/pkg-plist b/devel/global/pkg-plist
new file mode 100644
index 000000000000..24c14074390d
--- /dev/null
+++ b/devel/global/pkg-plist
@@ -0,0 +1,5 @@
+bin/global
+bin/gtags
+bin/gctags
+bin/btreeop
+bin/htags