aboutsummaryrefslogtreecommitdiff
path: root/devel/libnotify/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 06:53:44 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 06:53:44 +0000
commit5a1dd9dd1805928e34508dfba7509df14f834742 (patch)
tree050e6f90d9a6041bb397c0a50beb5ca3c9deaf81 /devel/libnotify/Makefile
parentfbe7dfc8bcdcc0f2440a1e34b31de651395f813b (diff)
downloadports-5a1dd9dd1805928e34508dfba7509df14f834742.tar.gz
ports-5a1dd9dd1805928e34508dfba7509df14f834742.zip
Notes
Diffstat (limited to 'devel/libnotify/Makefile')
-rw-r--r--devel/libnotify/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/libnotify/Makefile b/devel/libnotify/Makefile
new file mode 100644
index 000000000000..5a261ae9fc0c
--- /dev/null
+++ b/devel/libnotify/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libnotify
+# Date created: 2005-08-06
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnotify
+PORTVERSION= 0.2.1
+CATEGORIES= devel gnome
+MASTER_SITES= http://www.galago.info/files/releases/source/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= A library for desktop notifications
+
+LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus \
+ popt.0:${PORTSDIR}/devel/popt
+
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack glib20
+USE_GMAKE= yes
+USE_LIBTOOL_VER=15
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>