aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-11-15 19:01:29 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-11-15 19:01:29 +0000
commitea60463dee397b0b286c74d71a80f81d2e0b90b0 (patch)
treeac8e9d531ecc6b9c2b9c14bf29d9f8743093d4aa /dns/powerdns
parent018d7f39c9b4d74b52faa6df26b805b5d61e7002 (diff)
downloadports-ea60463dee397b0b286c74d71a80f81d2e0b90b0.tar.gz
ports-ea60463dee397b0b286c74d71a80f81d2e0b90b0.zip
dns/powerdns: Adjust dependencies for tools
- Adjust dependencies (IXFRTOOL needs yaml-cpp) - Explicitly disable decaf and sodium in case they are not enabled. Otherwise they default to "auto" and if detected in the system, stage-qa reports unresolved dependency. - Drop user privilges for worker processes to pdns/pdns (UID is new; GUID already exists) - Always depend on protobuf. I do the same for dnsdist and powerdns-recursor - Actually do something with the pdns_flags variable in the rc-script instead of just mentioning it in the comment block - Bump PORTREVISION PR: 250961 Submitted by: Juraj Lutter, Ralf van der Enden Approved by: Ralf van der Enden (maintainer)
Notes
Notes: svn path=/head/; revision=555419
Diffstat (limited to 'dns/powerdns')
-rw-r--r--dns/powerdns/Makefile22
-rw-r--r--dns/powerdns/files/pdns.in2
-rw-r--r--dns/powerdns/pkg-plist5
3 files changed, 18 insertions, 11 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 0919ec5abed3..c24a0011dfe4 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -2,6 +2,7 @@
PORTNAME= powerdns
DISTVERSION= 4.3.1
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= https://downloads.powerdns.com/releases/
DISTNAME= pdns-${DISTVERSION}
@@ -14,10 +15,12 @@ LICENSE= GPLv2
BROKEN_sparc64= Does not compile: error: to_string is not a member of std
LIB_DEPENDS= libboost_serialization.so:devel/boost-libs \
- libcurl.so:ftp/curl
+ libcurl.so:ftp/curl \
+ libprotobuf.so:devel/protobuf
USES= compiler:c++11-lib cpe gmake libtool localbase:ldflags pathfix \
pkgconfig ssl tar:bzip2
+
USE_LDCONFIG= YES
USE_RC_SUBR= pdns
USE_SUBMAKE= YES
@@ -28,7 +31,8 @@ CONFIGURE_ARGS= --disable-static \
--sysconfdir="${PREFIX}/etc/pdns" \
--with-boost="${LOCALBASE}" \
--with-dynmodules="pipe bind ${MODULES}" \
- --with-modules=""
+ --with-modules="" \
+ --with-protobuf
INSTALL_TARGET= install-strip
SCRIPTS_ENV= CURDIR2="${.CURDIR}" DISTNAME="${DISTNAME}" MKDIR="${MKDIR}" \
@@ -36,9 +40,12 @@ SCRIPTS_ENV= CURDIR2="${.CURDIR}" DISTNAME="${DISTNAME}" MKDIR="${MKDIR}" \
WRKDIRPREFIX="${WRKDIRPREFIX}"
SUB_FILES= pkg-message
+USERS= pdns
+GROUPS= pdns
+
OPTIONS_DEFINE= DOCS EXAMPLES GEOIP IXFRDIST LMDB LUABACKEND \
- MYSQL OPENLDAP PGSQL PROTOBUF REMOTE SQLITE3 \
- TINYDNS TOOLS UNIXODBC
+ MYSQL OPENLDAP PGSQL REMOTE SQLITE3 TINYDNS \
+ TOOLS UNIXODBC
OPTIONS_DEFAULT= LMDB LUA MYSQL PGSQL SQLITE3
OPTIONS_GROUP= GEOIPOPT REMOTEOPT
OPTIONS_GROUP_REMOTEOPT= ZEROMQ
@@ -58,7 +65,6 @@ LUA_DESC= Use lang/lua
MYSQL_DESC= MySQL backend
OPENLDAP_DESC= OpenLDAP backend
PGSQL_DESC= PostgreSQL backend
-PROTOBUF_DESC= Protobuf support
REMOTEOPT_DESC= Remote backend connectors
REMOTE_DESC= Remote backend
SQLITE3_DESC= SQLite 3 backend
@@ -70,6 +76,7 @@ GEOIP_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb \
libyaml-cpp.so:devel/yaml-cpp
GEOIP_VARS= MODULES+=geoip
+IXFRDIST_LIB_DEPENDS= libyaml-cpp.so:devel/yaml-cpp
IXFRDIST_CONFIGURE_ENABLE= ixfrdist
LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
@@ -100,9 +107,6 @@ PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pg-config=${LOCALBASE}/bin/pg_config
PGSQL_VARS= MODULES+=gpgsql
-PROTOBUF_LIB_DEPENDS= libprotobuf.so:devel/protobuf
-PROTOBUF_CONFIGURE_WITH= protobuf
-
REMOTE_VARS= MODULES+=remote
SQLITE3_USES= sqlite:3
@@ -129,6 +133,8 @@ CONFIGURE_ARGS+= --with-libdecaf \
--with-libsodium
LIB_DEPENDS+= libdecaf.so:security/libdecaf \
libsodium.so:security/libsodium
+.else
+CONFIGURE_ARGS+= --with-libsodium=no
.endif
post-install::
diff --git a/dns/powerdns/files/pdns.in b/dns/powerdns/files/pdns.in
index b3c0a61ec08c..8a8b3fa73456 100644
--- a/dns/powerdns/files/pdns.in
+++ b/dns/powerdns/files/pdns.in
@@ -31,7 +31,7 @@ required_files=${pdns_conf}
pidfile=/var/run/pdns/${name}.pid
command=%%PREFIX%%/sbin/pdns_server
-command_args="--daemon --guardian"
+command_args="${pdns_flags} --daemon --guardian"
monitor_cmd="${command} --daemon=no --guardian=no --control-console --loglevel=9"
extra_commands="monitor"
diff --git a/dns/powerdns/pkg-plist b/dns/powerdns/pkg-plist
index 03c1ed3fc114..1e1c3d3dd8b4 100644
--- a/dns/powerdns/pkg-plist
+++ b/dns/powerdns/pkg-plist
@@ -3,7 +3,7 @@ bin/pdnsutil
bin/zone2json
bin/zone2sql
sbin/pdns_server
-%%PROTOBUF%%bin/dnspcap2protobuf
+bin/dnspcap2protobuf
%%TOOLS%%bin/calidns
%%TOOLS%%bin/dnsbulktest
%%TOOLS%%bin/dnsgram
@@ -54,7 +54,7 @@ man/man1/pdns_server.1.gz
man/man1/zone2json.1.gz
%%OPENLDAP%%man/man1/zone2ldap.1.gz
man/man1/zone2sql.1.gz
-%%PROTOBUF%%man/man1/dnspcap2protobuf.1.gz
+man/man1/dnspcap2protobuf.1.gz
%%TOOLS%%man/man1/dnstcpbench.1.gz
%%TOOLS%%man/man1/dnsreplay.1.gz
%%TOOLS%%man/man1/dnsscope.1.gz
@@ -75,6 +75,7 @@ man/man1/zone2sql.1.gz
%%MYSQL%%%%PORTDOCS%%%%DOCSDIR%%/4.2.0_to_4.3.0_schema.mysql.sql
%%PGSQL%%%%PORTDOCS%%%%DOCSDIR%%/4.2.0_to_4.3.0_schema.pgsql.sql
%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/4.2.0_to_4.3.0_schema.sqlite3.sql
+%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/4.3.0_to_4.3.1_schema.sqlite3.sql
%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/bind-dnssec.4.2.0_to_4.3.0_schema.sqlite3.sql
%%SQLITE3%%%%PORTDOCS%%%%DOCSDIR%%/bind-dnssec.schema.sqlite3.sql
%%MYSQL%%%%PORTDOCS%%%%DOCSDIR%%/dnssec-3.x_to_3.4.0_schema.mysql.sql