aboutsummaryrefslogtreecommitdiff
path: root/editors/cooledit/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-12-15 15:21:50 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-12-15 15:21:50 +0000
commit9f6c3c0d1bdd3090a5fe8c31288f34d29c9adcf5 (patch)
treebaa9c51f744e91b62b16d20ec950fb01098aeee4 /editors/cooledit/Makefile
parent262787fd7748546df90d5aad2da6a84e8acb5ecb (diff)
Notes
Diffstat (limited to 'editors/cooledit/Makefile')
-rw-r--r--editors/cooledit/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index f63a89af406c..a2bf9908790e 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cooledit
-PORTVERSION= 3.17.8
+PORTVERSION= 3.17.14
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/editors/X/cooledit
@@ -22,25 +22,21 @@ USE_GMAKE= yes
USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOHEADER="${TRUE}" \
- AUTOMAKE="${TRUE}"
INSTALLS_SHLIB= yes
MAN1= cooledit.1 coolman.1 smalledit.1
-CPPFLAGS= -I${LOCALBASE}/include -DHAVE_GETTEXT ${PTHREAD_CFLAGS}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+CFLAGS+= -DHAVE_MBRTOWC
+.endif
+
.if defined(WITH_NEXT_LOOK)
CONFIGURE_ARGS+= --enable-NeXT-look
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|^PACKAGE_FORCE|#PACKAGE_FORGE|g ; \
- s|USE_INCLUDED_LIBINTL=yes|USE_INCLUDED_LIBINTL=no|g ; \
- s|\\$${top_builddir}/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|#undef HAVE_WCHAR_H||g ; \
- s|#undef HAVE_DCGETTEXT||g' ${WRKSRC}/config.h.in
- @${REINPLACE_CMD} -e 's|m4 intl rxvt|m4 rxvt|g' ${WRKSRC}/Makefile.in
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>