aboutsummaryrefslogtreecommitdiff
path: root/editors/tweak/files
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-21 09:02:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-02-21 09:02:56 +0000
commit6225d12a8176933ecb0485049eebb5ab046b29e7 (patch)
tree304bf28a4ec01bd84134de6b51e5bdb3ea8cdc25 /editors/tweak/files
parentc86a54ec8a687530b9d6634e38fe8792ad6af752 (diff)
Notes
Diffstat (limited to 'editors/tweak/files')
-rw-r--r--editors/tweak/files/Makefile.in7
-rw-r--r--editors/tweak/files/patch-Makefile42
2 files changed, 42 insertions, 7 deletions
diff --git a/editors/tweak/files/Makefile.in b/editors/tweak/files/Makefile.in
deleted file mode 100644
index 1f82158c7aa4..000000000000
--- a/editors/tweak/files/Makefile.in
+++ /dev/null
@@ -1,7 +0,0 @@
-# $FreeBSD$
-
-PROG= tweak
-SRCS= actions.c btree.c buffer.c curses.c keytab.c main.c rcfile.c search.c
-LDADD= -lncurses
-
-.include <bsd.prog.mk>
diff --git a/editors/tweak/files/patch-Makefile b/editors/tweak/files/patch-Makefile
new file mode 100644
index 000000000000..6174b9a7d1cd
--- /dev/null
+++ b/editors/tweak/files/patch-Makefile
@@ -0,0 +1,42 @@
+--- Makefile.orig 2016-03-22 21:12:51 UTC
++++ Makefile
+@@ -16,15 +16,16 @@
+ # number in tweak.h, or else the resulting binary won't match
+ # the version number on the archive.
+
+-CC := gcc
+-CFLAGS := -g -c -Wall $(XFLAGS)
+-LINK := gcc
+-LFLAGS :=
+-LIBS :=
++CC ?= gcc
++CFLAGS ?= -g
++CFLAGS += -c -Wall $(XFLAGS)
++LINK ?= ${CC}
++LFLAGS ?=
++LIBS ?=
+
+-PREFIX=$(DESTDIR)/usr/local
+-BINDIR=$(PREFIX)/bin
+-MANDIR=$(PREFIX)/man/man1
++PREFIX?=/usr/local
++BINDIR?=$(PREFIX)/bin
++MANDIR?=$(PREFIX)/man/man1
+
+ TWEAK := main.o keytab.o actions.o search.o rcfile.o buffer.o btree.o
+
+@@ -63,10 +64,10 @@ release: tweak.1 btree.html
+ rm -rf reltmp
+
+ install: tweak tweak.1
+- mkdir -p $(BINDIR)
+- install tweak $(BINDIR)/tweak
+- mkdir -p $(MANDIR)
+- install -m 0644 tweak.1 $(MANDIR)/tweak.1
++ mkdir -p $(DESTDIR)$(BINDIR)
++ install tweak $(DESTDIR)$(BINDIR)/tweak
++ mkdir -p $(DESTDIR)$(MANDIR)
++ install -m 0644 tweak.1 $(DESTDIR)$(MANDIR)/tweak.1
+
+ clean:
+ rm -f *.o tweak tweak.1 btree.html