aboutsummaryrefslogtreecommitdiff
path: root/editors/vim-tiny/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2018-01-08 19:44:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2018-01-08 19:44:13 +0000
commit1c095d9d53d64e968cce23b84649d896e39c1161 (patch)
tree7e29ca1cd3d83b813e8da78483a5db651348c0d9 /editors/vim-tiny/Makefile
parent34418aa70bdb705372eb21298f9adc4bb6fe56c3 (diff)
downloadports-1c095d9d53d64e968cce23b84649d896e39c1161.tar.gz
ports-1c095d9d53d64e968cce23b84649d896e39c1161.zip
Notes
Diffstat (limited to 'editors/vim-tiny/Makefile')
-rw-r--r--editors/vim-tiny/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/editors/vim-tiny/Makefile b/editors/vim-tiny/Makefile
new file mode 100644
index 000000000000..028e3344685f
--- /dev/null
+++ b/editors/vim-tiny/Makefile
@@ -0,0 +1,22 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -tiny
+
+COMMENT= Improved version of the vi editor (vim binary only)
+
+CONFLICTS_INSTALL= vim vim-lite
+
+TINY= yes
+MASTERDIR= ${.CURDIR}/../vim
+
+PORTDATA= # Not for -tiny
+PLIST= # Not for -tiny
+PLIST_FILES= bin/vim \
+ man/man1/vim.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/vim ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/runtime/doc/vim.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include "${MASTERDIR}/Makefile"