aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-04-03 20:35:24 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-04-03 20:35:24 +0000
commit7420d45d10bec5a011cac6c393aa0c5c7f086c16 (patch)
tree5d77be507aa3d53b7bb6a9365f11370eae34ce0c /emulators/mame
parent9f21cd5afcc3e29b6366e8da271ca7cefcd5b11f (diff)
downloadports-7420d45d10bec5a011cac6c393aa0c5c7f086c16.tar.gz
ports-7420d45d10bec5a011cac6c393aa0c5c7f086c16.zip
- Unbreak emulator/mess
- Use at least clang50 to build mame/mess. GCC is segfaulting during build on 10.4 and it doesn't build with clang. - Declare some dependencies explicitly to make Q/A happy
Notes
Notes: svn path=/head/; revision=466375
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index c5f0db89515b..73f94b1369fd 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -15,9 +15,11 @@ ONLY_FOR_ARCHS_REASON= not yet ported to any arch other than x86
LIB_DEPENDS= libFLAC.so:audio/flac \
libexpat.so:textproc/expat2 \
- libfontconfig.so:x11-fonts/fontconfig
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
RUN_DEPENDS= liberation-fonts-ttf>=0:x11-fonts/liberation-fonts-ttf
+USES= compiler:c11 gmake jpeg pkgconfig python:2.7,build shebangfix
USE_GITHUB= yes
GH_ACCOUNT= mamedev
GH_PROJECT= mame # explicit (master port)
@@ -28,10 +30,11 @@ OPTIONS_DEFINE= DEBUG DOCS EXAMPLES
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1100055
-USE_GCC= 6
+BUILD_DEPENDS+= clang50:devel/llvm50
+CC= clang50
+CXX= clang++50
.endif
-USES= compiler:c11 gmake jpeg pkgconfig python:2.7,build shebangfix
SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
src/devices/cpu/m6809/m6809make.py \
src/devices/cpu/mcs96/mcs96make.py \
@@ -39,7 +42,7 @@ SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
USE_XORG= x11 xext xi xinerama xrender
USE_GL= gl
USE_SDL= sdl2 ttf2
-USE_QT5= buildtools gui qmake_build widgets
+USE_QT5= buildtools core gui qmake_build widgets
MTARGET?= mame
MSUBTARGET?= mame
CFLAGS+= -I${LOCALBASE}/include
@@ -112,8 +115,9 @@ do-install:
${STAGEDIR}${PREFIX}/libexec/mame)
.endif
.if ${MSUBTARGET:Mmess}
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} castool chdman imgtool jedutil \
- ldresample ldverify romcmp testkeys unidasm \
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} castool chdman floptool imgtool jedutil \
+ ldresample ldverify nltool nlwav pngcmp regrep romcmp split src2html \
+ srcclean unidasm \
${STAGEDIR}${PREFIX}/libexec/mess)
.endif
(cd ${WRKSRC} && ${COPYTREE_SHARE} artwork ${STAGEDIR}${DATADIR})