aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2021-03-17 00:09:01 +0000
committerSanthosh Raju <fox@FreeBSD.org>2021-03-17 00:09:01 +0000
commitbdd81de5e5cd05dc3f46c77e76e8955c3ec53b49 (patch)
tree9ce3c64beca61bf98224ef2a2692c71b6b9cd1d4 /emulators
parentfd49889d8bafb2c1b5a6b017ec1735ad4465727e (diff)
downloadports-bdd81de5e5cd05dc3f46c77e76e8955c3ec53b49.tar.gz
ports-bdd81de5e5cd05dc3f46c77e76e8955c3ec53b49.zip
emulators/cannonball: Updates to 0.31
Changes since g20191023: Maintenance Release This release focuses on upgrading the libraries and compilation tools CannonBall uses, as I hadn't maintained the codebase in a number of years. Most of these changes will be invisible to most users. Right now, I'm trying to get the house in order as opposed to add lots of wild new features! :) * [audio] Audio updates at the correct rate and resolves the longstanding issue with music and sound being very slightly 'off' * [roms] ROMs are now read by CRC 32 value. Filenames no longer matter - so long as they are present they can be renamed to anything. * [roms] Fixed expected Z80 rom file length * [controls] Start Button behaviour less 'sticky' and buggy * [controls] Analog axis for accelerate and brake can now be configured via the in-built menu system * [menu] Reduced delay when scrolling through menu with analog controls * [config] ROMs and save data can be relocated to separate locations * [bug fix] Time Trial mode no longer crashes if used as the first mode played * [timing] Code tries to use V-Sync for timing OR internal timing, as opposed to both at once * [source] SDL 2 used by default. SDL 1 removed from codebase. This appears to have fixed compatibility bugs for some people * [source] Added compatibility for upcoming SmartyPi hardware (Pi 4 based) to run on original arcade hardware * [source] A general clean-up in many areas
Notes
Notes: svn path=/head/; revision=568624
Diffstat (limited to 'emulators')
-rw-r--r--emulators/cannonball/Makefile15
-rw-r--r--emulators/cannonball/distinfo6
-rw-r--r--emulators/cannonball/files/patch-cmake_linux.cmake20
3 files changed, 31 insertions, 10 deletions
diff --git a/emulators/cannonball/Makefile b/emulators/cannonball/Makefile
index cb33ca863a12..b1656b1d28ba 100644
--- a/emulators/cannonball/Makefile
+++ b/emulators/cannonball/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cannonball
-DISTVERSION= g20191023
-PORTREVISION= 1
+DISTVERSION= 0.31
CATEGORIES= emulators games
MAINTAINER= fox@FreeBSD.org
@@ -13,18 +12,20 @@ LICENSE_NAME= MAME license
LICENSE_FILE= ${WRKSRC}/docs/license.txt
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
-LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/exception/all.hpp:devel/boost-libs
-USES= cmake:insource pkgconfig sdl
+USES= cmake:insource gl pkgconfig sdl
USE_SDL= sdl2
+USE_GL= gl glu
CMAKE_ARGS+= ${WRKSRC}/cmake \
- -DBSD_PREFIX_PATH=${LOCALBASE} \
- -DTARGET=bsd
+ -DTARGET=linux.cmake
+
+CFLAGS+= -I${LOCALBASE}/include
USE_GITHUB= yes
GH_ACCOUNT= djyt
-GH_TAGNAME= b6aa525
+GH_TAGNAME= v${DISTVERSION}
BUILD_WRKSRC= ${WRKSRC}/cmake
CONFIGURE_WRKSRC= ${WRKSRC}/cmake
diff --git a/emulators/cannonball/distinfo b/emulators/cannonball/distinfo
index 7030a63031b5..fb8b58c662dd 100644
--- a/emulators/cannonball/distinfo
+++ b/emulators/cannonball/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1571852926
-SHA256 (djyt-cannonball-g20191023-b6aa525_GH0.tar.gz) = 4ddc436505392c635eed6d0f770792cab115a440db586851196c82ce33c2c196
-SIZE (djyt-cannonball-g20191023-b6aa525_GH0.tar.gz) = 278312
+TIMESTAMP = 1615884344
+SHA256 (djyt-cannonball-0.31-v0.31_GH0.tar.gz) = 8743fcfabeeaf8820ab47196e1b29b1702c1f71b784b6336f79d5f8725bc561b
+SIZE (djyt-cannonball-0.31-v0.31_GH0.tar.gz) = 269125
diff --git a/emulators/cannonball/files/patch-cmake_linux.cmake b/emulators/cannonball/files/patch-cmake_linux.cmake
new file mode 100644
index 000000000000..c2bc805f8646
--- /dev/null
+++ b/emulators/cannonball/files/patch-cmake_linux.cmake
@@ -0,0 +1,20 @@
+Adds support for building in BSD.
+
+Will be removed once upstream makes a release with
+https://github.com/djyt/cannonball/commit/a9c71cbf229b9f808ae172a09d12a773fc869209
+
+--- cmake/linux.cmake.orig 2021-03-16 11:22:26 UTC
++++ cmake/linux.cmake
+@@ -0,0 +1,12 @@
++# -----------------------------------------------------------------------------
++# CannonBall BSD Setup
++# -----------------------------------------------------------------------------
++
++# Use OpenGL for rendering.
++find_package(OpenGL REQUIRED)
++
++# Platform Specific Libraries
++set(platform_link_libs
++ ${OPENGL_LIBRARIES}
++)
++