aboutsummaryrefslogtreecommitdiff
path: root/finance/cbb
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-17 16:41:21 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-17 16:41:21 +0000
commitd60d13a4633042f2063ff19049c26ba07d440eb7 (patch)
tree7629240bbfabc978e53a8807fa2593c59e921129 /finance/cbb
parent028b79449fa1bb52604a68deeb5050e802bcffb3 (diff)
downloadports-d60d13a4633042f2063ff19049c26ba07d440eb7.tar.gz
ports-d60d13a4633042f2063ff19049c26ba07d440eb7.zip
Notes
Diffstat (limited to 'finance/cbb')
-rw-r--r--finance/cbb/Makefile10
-rw-r--r--finance/cbb/files/patch-Makefile.in37
-rw-r--r--finance/cbb/files/patch-contrib_Makefile.in37
-rw-r--r--finance/cbb/files/patch-docs-cbb-man-icons.png_Makefile.in37
-rw-r--r--finance/cbb/files/patch-docs-cbb-man_Makefile.in37
-rw-r--r--finance/cbb/files/patch-docs_Makefile.in37
-rw-r--r--finance/cbb/files/patch-etc_Makefile.in37
-rw-r--r--finance/cbb/files/patch-graphs_Makefile.in37
-rw-r--r--finance/cbb/files/patch-images_Makefile.in37
-rw-r--r--finance/cbb/files/patch-languages_Makefile.in37
-rw-r--r--finance/cbb/files/patch-perl_Makefile.in37
-rw-r--r--finance/cbb/files/patch-reports_Makefile.in37
-rw-r--r--finance/cbb/files/patch-tcl_Makefile.in37
13 files changed, 451 insertions, 3 deletions
diff --git a/finance/cbb/Makefile b/finance/cbb/Makefile
index 0fd7d9dc2d75..4eab111239e9 100644
--- a/finance/cbb/Makefile
+++ b/finance/cbb/Makefile
@@ -10,21 +10,25 @@ EXTRACT_SUFX= .tgz
MAINTAINER= kline@thought.org
COMMENT= Checkbook balancing tool
-USE_TK= yes
+LICENSE= GPLv2
NO_BUILD= yes
-USES= perl5
+USES= shebangfix perl5 tk
+SHEBANG_FILES= tcl/*.tcl */*.pl contrib/*
+SHEBANG_LANG= perl tk
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-perl=${PERL} \
--with-wish=${WISH}
+MAKE_ENV+= STAGEDIR=${STAGEDIR}
WRKSRC= ${WRKDIR}/${PKGNAME:R}
PLIST_SUB+= VERSION=${PORTVERSION:R:R}
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's|.aboutwin.frame.a.l6 ||' \
${WRKSRC}/tcl/help.tcl
${REINPLACE_CMD} -e 's|%4Y%02m%02d|%Y%m%d|' \
${WRKSRC}/tcl/main.tcl
+ ${REINPLACE_CMD} -e 's|/usr/bin/perl|${TCLSH}|' \
+ ${WRKSRC}/languages/*.tcl
.include <bsd.port.mk>
diff --git a/finance/cbb/files/patch-Makefile.in b/finance/cbb/files/patch-Makefile.in
new file mode 100644
index 000000000000..45f3ff704215
--- /dev/null
+++ b/finance/cbb/files/patch-Makefile.in
@@ -0,0 +1,37 @@
+--- Makefile.in.orig 2001-08-15 03:56:01.000000000 +0200
++++ Makefile.in 2014-02-17 17:10:53.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -305,19 +305,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-contrib_Makefile.in b/finance/cbb/files/patch-contrib_Makefile.in
new file mode 100644
index 000000000000..c294825c332a
--- /dev/null
+++ b/finance/cbb/files/patch-contrib_Makefile.in
@@ -0,0 +1,37 @@
+--- contrib/Makefile.in.orig 2014-02-17 16:54:57.000000000 +0100
++++ contrib/Makefile.in 2014-02-17 16:55:36.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -182,19 +182,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-docs-cbb-man-icons.png_Makefile.in b/finance/cbb/files/patch-docs-cbb-man-icons.png_Makefile.in
new file mode 100644
index 000000000000..336fbbaa4e68
--- /dev/null
+++ b/finance/cbb/files/patch-docs-cbb-man-icons.png_Makefile.in
@@ -0,0 +1,37 @@
+--- docs/cbb-man/icons.png/Makefile.in.orig 2014-02-17 17:04:22.000000000 +0100
++++ docs/cbb-man/icons.png/Makefile.in 2014-02-17 17:04:51.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -189,19 +189,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-docs-cbb-man_Makefile.in b/finance/cbb/files/patch-docs-cbb-man_Makefile.in
new file mode 100644
index 000000000000..260383c8e017
--- /dev/null
+++ b/finance/cbb/files/patch-docs-cbb-man_Makefile.in
@@ -0,0 +1,37 @@
+--- docs/cbb-man/Makefile.in.orig 2014-02-17 17:01:47.000000000 +0100
++++ docs/cbb-man/Makefile.in 2014-02-17 17:02:18.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -260,19 +260,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-docs_Makefile.in b/finance/cbb/files/patch-docs_Makefile.in
new file mode 100644
index 000000000000..8c0db08623b6
--- /dev/null
+++ b/finance/cbb/files/patch-docs_Makefile.in
@@ -0,0 +1,37 @@
+--- docs/Makefile.in.orig 2014-02-17 16:56:01.000000000 +0100
++++ docs/Makefile.in 2014-02-17 16:56:49.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -264,19 +264,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-etc_Makefile.in b/finance/cbb/files/patch-etc_Makefile.in
new file mode 100644
index 000000000000..05ef51ec0e6a
--- /dev/null
+++ b/finance/cbb/files/patch-etc_Makefile.in
@@ -0,0 +1,37 @@
+--- etc/Makefile.in.orig 2014-02-17 16:57:08.000000000 +0100
++++ etc/Makefile.in 2014-02-17 16:57:44.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -165,19 +165,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-graphs_Makefile.in b/finance/cbb/files/patch-graphs_Makefile.in
new file mode 100644
index 000000000000..3ee67c2301c5
--- /dev/null
+++ b/finance/cbb/files/patch-graphs_Makefile.in
@@ -0,0 +1,37 @@
+--- graphs/Makefile.in.orig 2014-02-17 16:58:03.000000000 +0100
++++ graphs/Makefile.in 2014-02-17 16:58:31.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -197,19 +197,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-images_Makefile.in b/finance/cbb/files/patch-images_Makefile.in
new file mode 100644
index 000000000000..3495c18895da
--- /dev/null
+++ b/finance/cbb/files/patch-images_Makefile.in
@@ -0,0 +1,37 @@
+--- images/Makefile.in.orig 2014-02-17 16:59:00.000000000 +0100
++++ images/Makefile.in 2014-02-17 16:59:31.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -168,19 +168,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-languages_Makefile.in b/finance/cbb/files/patch-languages_Makefile.in
new file mode 100644
index 000000000000..f621dbec20f0
--- /dev/null
+++ b/finance/cbb/files/patch-languages_Makefile.in
@@ -0,0 +1,37 @@
+--- languages/Makefile.in.orig 2014-02-17 17:05:32.000000000 +0100
++++ languages/Makefile.in 2014-02-17 17:06:03.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -166,19 +166,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-perl_Makefile.in b/finance/cbb/files/patch-perl_Makefile.in
new file mode 100644
index 000000000000..5d1203429ae1
--- /dev/null
+++ b/finance/cbb/files/patch-perl_Makefile.in
@@ -0,0 +1,37 @@
+--- perl/Makefile.in.orig 2014-02-17 17:06:57.000000000 +0100
++++ perl/Makefile.in 2014-02-17 17:07:25.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -174,19 +174,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-reports_Makefile.in b/finance/cbb/files/patch-reports_Makefile.in
new file mode 100644
index 000000000000..812a1e772978
--- /dev/null
+++ b/finance/cbb/files/patch-reports_Makefile.in
@@ -0,0 +1,37 @@
+--- reports/Makefile.in.orig 2014-02-17 17:08:01.000000000 +0100
++++ reports/Makefile.in 2014-02-17 17:08:39.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -188,19 +188,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook:
diff --git a/finance/cbb/files/patch-tcl_Makefile.in b/finance/cbb/files/patch-tcl_Makefile.in
new file mode 100644
index 000000000000..94c482c6af9b
--- /dev/null
+++ b/finance/cbb/files/patch-tcl_Makefile.in
@@ -0,0 +1,37 @@
+--- tcl/Makefile.in.orig 2014-02-17 17:09:00.000000000 +0100
++++ tcl/Makefile.in 2014-02-17 17:09:36.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -179,19 +179,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook: