aboutsummaryrefslogtreecommitdiff
path: root/ftp/proftpd
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-03-27 23:31:52 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-03-27 23:31:52 +0000
commitd052a5a0d21edb004dcf5711028826d7b16d76c8 (patch)
tree3798ae46b698da4a906adbe57cba4fec8dffaabe /ftp/proftpd
parent68eeec6389133d0d1210a2b87a4d5cc10981736b (diff)
downloadports-d052a5a0d21edb004dcf5711028826d7b16d76c8.tar.gz
ports-d052a5a0d21edb004dcf5711028826d7b16d76c8.zip
Allow specification of custom ProFTPD configuration file
PR: ports/187678 Submitted by: Daniel Ylitalo <daniel@blodan.se>
Notes
Notes: svn path=/head/; revision=349374
Diffstat (limited to 'ftp/proftpd')
-rw-r--r--ftp/proftpd/Makefile2
-rw-r--r--ftp/proftpd/files/proftpd.in16
2 files changed, 8 insertions, 10 deletions
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 1945e5d5eff1..7a61eb97fd43 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -5,7 +5,7 @@ PORTNAME?= proftpd
.if !defined(DISTVERSION)
PORTVERSION?= ${PROFTPD_VERSION}
.endif
-PORTREVISION?= 4
+PORTREVISION?= 5
CATEGORIES?= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
https://github.com/downloads/proftpd/proftpd.github.com/ \
diff --git a/ftp/proftpd/files/proftpd.in b/ftp/proftpd/files/proftpd.in
index a4674f2bb49b..cf2a338c7e75 100644
--- a/ftp/proftpd/files/proftpd.in
+++ b/ftp/proftpd/files/proftpd.in
@@ -22,22 +22,20 @@
name=proftpd
rcvar=proftpd_enable
+proftpd_enable=${proftpd_enable:="NO"}
+proftpd_config=${proftpd_config:="%%PREFIX%%/etc/proftpd.conf"}
+
command=%%PREFIX%%/sbin/proftpd
-pidfile=$(grep PidFile /usr/local/etc/proftpd.conf | awk '{print($2)}')
-required_files=%%PREFIX%%/etc/proftpd.conf
+command_args="-c ${proftpd_config}"
+pidfile=$(grep PidFile ${proftpd_config} | awk '{print($2)}')
+required_files=${proftpd_config}
+extra_commands="reload"
stop_postcmd=stop_postcmd
-
stop_postcmd()
{
rm -f $pidfile
}
-# set defaults
-
-proftpd_enable=${proftpd_enable:-"NO"}
-
-extra_commands="reload"
-
load_rc_config $name
run_rc_command "$1"