aboutsummaryrefslogtreecommitdiff
path: root/games/joequake/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:16:14 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-05 22:16:14 +0000
commitbe6c15b5c6de864408ba3f414a57f20ff622a2d0 (patch)
tree86bd1ae6afedaa57f4eef276444e85b00f8c8e63 /games/joequake/Makefile
parent2428d822895b6225746f9e1d2bed3143711fcf14 (diff)
Add USES=xorg USES=gl, ports categories g
Add USES=xorg and USES=gl to ports in categories starting with 'g'. While here, try to sprinkle other USES (mostly gnome and sdl) as needed.
Notes
Notes: svn path=/head/; revision=516845
Diffstat (limited to 'games/joequake/Makefile')
-rw-r--r--games/joequake/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/joequake/Makefile b/games/joequake/Makefile
index f919edc42f86..c67f78a03424 100644
--- a/games/joequake/Makefile
+++ b/games/joequake/Makefile
@@ -39,8 +39,8 @@ X86_ASM_DESC= Enable x86 assembly code
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENGL}
+USES+= gl jpeg
USE_GL= yes
-USES+= jpeg
ALL_TARGET+= glx
PLIST_SUB+= GLX=""
.else
@@ -76,6 +76,7 @@ MAKE_ENV+= USE_${f}=NO
.endfor
.if ${PORT_OPTIONS:MX11}
+USES+= xorg
USE_XORG= xxf86dga
ALL_TARGET+= x11
PLIST_SUB+= X11=""