aboutsummaryrefslogtreecommitdiff
path: root/games/joequake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/joequake/Makefile')
-rw-r--r--games/joequake/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/joequake/Makefile b/games/joequake/Makefile
index f919edc42f86..c67f78a03424 100644
--- a/games/joequake/Makefile
+++ b/games/joequake/Makefile
@@ -39,8 +39,8 @@ X86_ASM_DESC= Enable x86 assembly code
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOPENGL}
+USES+= gl jpeg
USE_GL= yes
-USES+= jpeg
ALL_TARGET+= glx
PLIST_SUB+= GLX=""
.else
@@ -76,6 +76,7 @@ MAKE_ENV+= USE_${f}=NO
.endfor
.if ${PORT_OPTIONS:MX11}
+USES+= xorg
USE_XORG= xxf86dga
ALL_TARGET+= x11
PLIST_SUB+= X11=""