aboutsummaryrefslogtreecommitdiff
path: root/games/openmortal/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-20 14:01:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-20 14:01:06 +0000
commitdf841b86f9accc4dbac6f2ef99efd0a8bec4925c (patch)
treef24b2b06148ed2969fe6006b53255614bfb800dc /games/openmortal/Makefile
parent17b42fa78f5c9208eef84fc6e5e56c3b7e1676ad (diff)
downloadports-df841b86f9accc4dbac6f2ef99efd0a8bec4925c.tar.gz
ports-df841b86f9accc4dbac6f2ef99efd0a8bec4925c.zip
Notes
Diffstat (limited to 'games/openmortal/Makefile')
-rw-r--r--games/openmortal/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
new file mode 100644
index 000000000000..1572eb455e62
--- /dev/null
+++ b/games/openmortal/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: openmortal
+# Date created: 20 Apr 2004
+# Whom: krion@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= openmortal
+PORTVERSION= 0.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= A parody of the once popular coin-up fighting game, Mortal Kombat
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_REINPLACE= yes
+USE_SDL= mixer image sdl net
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC}/src -name "*.cpp" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' -e 's|<malloc.h>|<stdlib.h>|g'
+ @${FIND} ${WRKSRC} -name "*.h" | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' -e 's|<malloc.h>|<stdlib.h>|g'
+
+.include <bsd.port.mk>