aboutsummaryrefslogtreecommitdiff
path: root/games/quake3-data
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:59:18 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:59:18 +0000
commit7146cbc5d73c74006aad743cc648199e755b3f49 (patch)
tree0d0851281f2ec920960ee113bc90e8c90fb8b5a2 /games/quake3-data
parentfc631bd198463ccfb8fa6d003bb0f253491bdefd (diff)
downloadports-7146cbc5d73c74006aad743cc648199e755b3f49.tar.gz
ports-7146cbc5d73c74006aad743cc648199e755b3f49.zip
[MAINTAINER UPDATE] games/quake3-data: redesign, change dependant ports
- Changed quake3-data/Makefile.include to be more similar to bsd.*.mk files, also it doesn't override port's variables. - Change dependant ports. PR: ports/90149 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=151623
Diffstat (limited to 'games/quake3-data')
-rw-r--r--games/quake3-data/Makefile3
-rw-r--r--games/quake3-data/Makefile.include49
2 files changed, 22 insertions, 30 deletions
diff --git a/games/quake3-data/Makefile b/games/quake3-data/Makefile
index 906e61d1a266..e176c25ae6d1 100644
--- a/games/quake3-data/Makefile
+++ b/games/quake3-data/Makefile
@@ -10,6 +10,7 @@ DISTVERSION= 1.32b-3
CATEGORIES= games
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/quake3/linux/ \
ftp://ftp.fasta.fh-dortmund.de/mirror/idstuff/quake3/linux/
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= linuxq3apoint-${DISTVERSION}.x86
EXTRACT_SUFX= .run
@@ -21,6 +22,8 @@ NO_WRKSUBDIR= yes
OPTIONS= TEAMARENA "Install Quake III Team Arena data files" on
+DATADIR= ${Q3DIR}
+
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
index cede8bcd61de..e2a071493c47 100644
--- a/games/quake3-data/Makefile.include
+++ b/games/quake3-data/Makefile.include
@@ -1,44 +1,33 @@
-# Makefile for defining variables used by other Quake III Arena related ports.
+# Makefile for defining variables used by other Doom related ports.
-# Package name prefix.
+# Set variables.
-Q3PKGNAMEPREFIX=quake3-
+Q3PKGNAMEPREFIX?=quake3-
+Q3DIR?= ${LOCALBASE}/share/quake3
-.if ${PORTNAME} != "quake3"
-PKGNAMEPREFIX?= ${Q3PKGNAMEPREFIX}
-.endif
+# Add them to the environment.
+
+MAKE_ENV+= Q3DIR="${Q3DIR}"
+PLIST_SUB+= Q3DIR="${Q3DIR:S/${LOCALBASE}\///}"
+SUB_LIST+= Q3DIR="${Q3DIR}"
-# Dependency to "games/quake3-data".
+# Add the dependency.
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${Q3DIR}/baseq3/pak1.pk3:${PORTSDIR}/games/quake3-data
.endif
-# Installation directories.
-
-Q3DIR= ${LOCALBASE}/share/quake3
-
-.if ${PORTNAME} == "data" || ${PORTNAME} == "quake3"
-DATADIR?= ${Q3DIR}
-.else
-DATADIR?= ${Q3DIR}/${PORTNAME}
-.endif
+# DOS to Unix text conversion.
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-PLIST_SUB+= Q3DIR="${Q3DIR:S/${PREFIX}\///}"
-
-# Convert "dos" text files to "unix".
-
-.if defined(USE_ZIP)
+.if defined(USE_CRLF)
+. if defined(USE_ZIP)
EXTRACT_BEFORE_ARGS= -aqo
-.else
+. else
USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
-
pre-patch:
-# remove trailing ^M
- @${FIND} -E ${WRKSRC} -type f \
- -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
- -exec ${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" {} \;
+ @${FIND} ${WRKDIR} -type f -print0 | \
+ ${XARGS} -0 ${FILE} | ${GREP} 'CRLF' | \
+ ${SED} -e "s/:.*//" | ${SED} -e 's/ /\\ /g' | \
+ ${XARGS} ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
+. endif
.endif