aboutsummaryrefslogtreecommitdiff
path: root/games/smashbattle
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-13 23:50:44 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-13 23:50:44 +0000
commitb210f655772266b90726639d815f8e54abcf20cb (patch)
tree837d230a1ff0a273f6a87cf6de777395b0290941 /games/smashbattle
parentc755a680b5cdf95699204f29bae336936af6911b (diff)
downloadports-b210f655772266b90726639d815f8e54abcf20cb.tar.gz
ports-b210f655772266b90726639d815f8e54abcf20cb.zip
Notes
Diffstat (limited to 'games/smashbattle')
-rw-r--r--games/smashbattle/Makefile31
-rw-r--r--games/smashbattle/files/smashbattle.in1
2 files changed, 16 insertions, 16 deletions
diff --git a/games/smashbattle/Makefile b/games/smashbattle/Makefile
index 5f7f830f324b..72e4171c23a5 100644
--- a/games/smashbattle/Makefile
+++ b/games/smashbattle/Makefile
@@ -15,35 +15,34 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/battle/Battle
USE_ZIP= yes
EXTRACT_AFTER_ARGS= -d ${WRKDIR}/${DISTNAME}
-USES= gmake
+USES= dos2unix gmake
+DOS2UNIX_FILES= *.cpp *.h Makefile
USE_SDL= sdl image mixer
-USE_DOS2UNIX= *.cpp *.h *.ini Makefile
ALL_TARGET= battle
-NO_STAGE= yes
pre-extract:
@${MKDIR} ${WRKDIR}/${DISTNAME}
SUB_FILES= ${PORTNAME}
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} \
- -e 's|CC=|CC?=|' \
- -e 's|CFLAGS=-c -Wall|CFLAGS += $$(shell sdl-config --cflags) -c -Wall|' \
- -e 's|LDFLAGS=-lSDL -lSDL_mixer -lz -lstdc++|LDFLAGS += $$(shell $${SDL_CONFIG} --libs) -lSDL -lSDL_mixer -lz -lstdc++ -lm|' \
+ -e 's|CC=|CC?=| ; \
+ s|CFLAGS=-c -Wall|CFLAGS += $$(shell sdl-config --cflags) -c -w| ; \
+ s|LDFLAGS=-lSDL -lSDL_mixer -lz -lstdc++|LDFLAGS += $$(shell $${SDL_CONFIG} --libs) -lSDL -lSDL_mixer -lz -lstdc++ -lm|' \
${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|/usr/share/games/smashbattle/gfx/SB.png|${PORTNAME}|' \
- -e 's|/usr/local/bin/smashbattle|${PORTNAME}|' \
+ @${REINPLACE_CMD} -e 's|/usr/share/games/smashbattle/gfx/SB.png|${PORTNAME}| ; \
+ s|/usr/local/bin/smashbattle|${PORTNAME}|' \
${WRKSRC}/linux/*.desktop
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "gfx music sfx stage" ${DATADIR})
- ${INSTALL_PROGRAM} ${WRKSRC}/battle ${DATADIR}/${PORTNAME}
- ${LN} -sf ${DATADIR}/gfx/SB.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-# ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${PREFIX}/share/applications/
- ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${DESKTOPDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+.for d in gfx music sfx stage
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/battle ${STAGEDIR}${DATADIR}/${PORTNAME}
+ ${LN} -sf ${DATADIR}/gfx/SB.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${STAGEDIR}${DESKTOPDIR}
.include <bsd.port.mk>
diff --git a/games/smashbattle/files/smashbattle.in b/games/smashbattle/files/smashbattle.in
index b9d105b6794d..cdfe8230e1d7 100644
--- a/games/smashbattle/files/smashbattle.in
+++ b/games/smashbattle/files/smashbattle.in
@@ -1,6 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+#
cd "%%DATADIR%%"
exec ./smashbattle "${@}"