aboutsummaryrefslogtreecommitdiff
path: root/games/sol
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-16 14:31:54 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-16 14:31:54 +0000
commit217ed45bf94757c34f79783b7402354783903558 (patch)
treeda504f9b49b4e741a0dee923eab380ffe34bef30 /games/sol
parent46d8696533b8961d0b96df54b52cef8db01b7890 (diff)
downloadports-217ed45bf94757c34f79783b7402354783903558.tar.gz
ports-217ed45bf94757c34f79783b7402354783903558.zip
- Update MASTER_SITES and WWW: line of pkg/DESCR
- Support CC/CFLAGS/PREFIX/LOCALBASE/X11BASE/etc properly PR: 19757 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=30703
Diffstat (limited to 'games/sol')
-rw-r--r--games/sol/Makefile28
-rw-r--r--games/sol/files/patch-aa43
-rw-r--r--games/sol/pkg-descr2
3 files changed, 53 insertions, 20 deletions
diff --git a/games/sol/Makefile b/games/sol/Makefile
index ed97790c8f1e..863aa6a580c8 100644
--- a/games/sol/Makefile
+++ b/games/sol/Makefile
@@ -8,7 +8,7 @@
PORTNAME= sol
PORTVERSION= 1.0.6
CATEGORIES= games
-MASTER_SITES= http://home.sol.no/~sverrehu/pub-unix/files/
+MASTER_SITES= http://shh.thathost.com/pub-unix/files/
MAINTAINER= ports@FreeBSD.org
@@ -24,17 +24,19 @@ USE_X_PREFIX= yes
MAN6= sol.6
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/sol
- @ ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
- @ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
- @ ${MKDIR} ${PREFIX}/share/doc/sol
- @ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
- @ ${CHOWN} root:games ${PREFIX}/bin/sol
- @ ${CHOWN} root:games ${PREFIX}/share/sol/sol.score
- @ ${CHMOD} 2755 ${PREFIX}/bin/sol
- @ ${CHMOD} 770 ${PREFIX}/share/sol
- @ ${CHMOD} 660 ${PREFIX}/share/sol/sol.score
+ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
+ @${MKDIR} ${PREFIX}/share/sol
+ ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
+ @${CHOWN} root:games ${PREFIX}/bin/sol
+ @${CHOWN} root:games ${PREFIX}/share/sol/sol.score
+ @${CHMOD} 2755 ${PREFIX}/bin/sol
+ @${CHMOD} 770 ${PREFIX}/share/sol
+ @${CHMOD} 660 ${PREFIX}/share/sol/sol.score
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
+.endif
.include <bsd.port.mk>
diff --git a/games/sol/files/patch-aa b/games/sol/files/patch-aa
index 1b870204ad4c..9af1c970551b 100644
--- a/games/sol/files/patch-aa
+++ b/games/sol/files/patch-aa
@@ -1,6 +1,18 @@
---- Makefile.orig Sun Jul 5 03:30:26 1998
-+++ Makefile Sun May 30 21:12:31 1999
-@@ -53,16 +53,16 @@
+--- Makefile.orig Sun Jul 5 17:30:26 1998
++++ Makefile Tue Jul 4 21:59:11 2000
+@@ -13,9 +13,8 @@
+ # Where are shhmsg, shhopt, xalloc, shhcards, Xpm and X11?
+
+ # GNU/Linux at home
+-INCDIR = -I/usr/local/include -I/usr/X11R6/include \
+- -I/usr/local/include/X11
+-LIBDIR = -L/usr/local/lib -L/usr/X11R6/lib -L/usr/local/lib/X11
++INCDIR = -I${LOCALBASE}/include -I${X11BASE}/include
++LIBDIR = -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+ # Irix at Ifi
+ ifeq ($(HOSTTYPE),sgi)
+@@ -53,18 +52,18 @@
endif
# DEC Alpha at USIT
@@ -19,7 +31,26 @@
# Where do you want to install the program and the highscore file?
-INSTLIBDIR = /var/local/lib/games
-+INSTLIBDIR = /usr/X11R6/share/sol
- INSTBINDIR = /usr/local/games
- INSTMANDIR = /usr/local/man/man6
+-INSTBINDIR = /usr/local/games
+-INSTMANDIR = /usr/local/man/man6
++INSTLIBDIR = ${PREFIX}/share/sol
++INSTBINDIR = ${PREFIX}/bin
++INSTMANDIR = ${PREFIX}/man/man6
#INSTLIBDIR = /hom/sverrehu/lib
+ #INSTBINDIR = /hom/sverrehu/bin/$$HOSTTYPE
+ #INSTMANDIR = /hom/sverrehu/man/man6
+@@ -84,11 +83,11 @@
+
+ ###########################################################################
+
+-CC = gcc
++#CC = gcc
+
+ OPTIM = -s -O2
+-CCOPT = -Wall $(OPTIM) $(INCDIR) $(DEFINES) $(CFLAGS)
+-LDOPT = -s $(LIBDIR) $(LDFLAGS) $(EXTRA_LD_OPT)
++CCOPT = $(INCDIR) $(DEFINES) $(CFLAGS)
++LDOPT = $(LIBDIR) $(LDFLAGS) $(EXTRA_LD_OPT)
+
+ LIBS = -lshhopt -lshhmsg -lxalloc -lshhcards \
+ -lXaw -lXt -lXpm -lXext -lXmu -lX11 $(EXTRA_LIBS)
diff --git a/games/sol/pkg-descr b/games/sol/pkg-descr
index 32c246e5dd5e..19404f96baba 100644
--- a/games/sol/pkg-descr
+++ b/games/sol/pkg-descr
@@ -2,4 +2,4 @@ This is a Solitaire card game highly inspired by the one
bundeled with a well known "operating system". Features
a site-wide highscore table.
-WWW: http://home.sol.no/~sverrehu/pub-unix/html/sol.html
+WWW: http://shh.thathost.com/pub-unix/#sol