aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-igeoportal
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-30 22:06:40 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-30 22:06:40 +0000
commit13c8106d8b8fbc29ecf19c068a7a8d5baebd184e (patch)
tree165db90905485739158776b49d90cc916c28503b /graphics/deegree-igeoportal
parent723b57e8dff31523693cbb832d128f35c48ddbba (diff)
downloadports-13c8106d8b8fbc29ecf19c068a7a8d5baebd184e.tar.gz
ports-13c8106d8b8fbc29ecf19c068a7a8d5baebd184e.zip
- add additional support for tomcat7 and adjust pkg-message accordingly
PR: 173091 Submitted by: nemysis@gmx.ch Patch by: jgh Approved by: maintainer, wen Feature safe: yes
Notes
Notes: svn path=/head/; revision=306721
Diffstat (limited to 'graphics/deegree-igeoportal')
-rw-r--r--graphics/deegree-igeoportal/Makefile41
-rw-r--r--graphics/deegree-igeoportal/files/pkg-message.in (renamed from graphics/deegree-igeoportal/pkg-message)2
2 files changed, 29 insertions, 14 deletions
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index 9c40f70752a9..9937369fc6cd 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -1,4 +1,4 @@
-# Created by: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
@@ -13,36 +13,51 @@ DISTNAME= ${PORTNAME}-std_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Browser based client handling WMS, WFS, and proxy service
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
-
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
+APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
-PORTDOCS= *
+PORTDOCS= README.txt README_owswatch.txt deegree_igeoportal_documentation_en.pdf
DOCSDIR= ${PREFIX}/share/doc/deegree-igeoportal
PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||}
+SUB_FILES= pkg-message
+SUB_LIST= TCPORT=${TCPORT}
+
+OPTIONS_SINGLE= AS
+OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
+OPTIONS_DEFAULT= TOMCAT6
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTOMCAT6}
+TOMCATVER= apache-tomcat-6.0
+TCPORT= 8180
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+.endif
+
+.if ${PORT_OPTIONS:MTOMCAT7}
+TOMCATVER= apache-tomcat-7.0
+TCPORT= 8080
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+.endif
post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/igeoportal-std.war -C ${WRKDIR}/${PORTDIRNAME}
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
- @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
+ ${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
+ @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/deegree_igeoportal_documentation_en.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${DOCSDIR}
.endif
-
-post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/deegree-igeoportal/pkg-message b/graphics/deegree-igeoportal/files/pkg-message.in
index f352845f2de7..c2555f83df04 100644
--- a/graphics/deegree-igeoportal/pkg-message
+++ b/graphics/deegree-igeoportal/files/pkg-message.in
@@ -4,7 +4,7 @@ To start DeeGree correctly, please set the variable JAVA_OPTS with:
setenv JAVA_OPTS "-server -Xms256m -Xmx512m"
Now you should start your Tomcat server and browse with:
- http://your-server:8180/deegree-igeoportal
+ http://your-server:%%TCPORT%%/deegree-igeoportal
Enjoy it !
==========================================================================