aboutsummaryrefslogtreecommitdiff
path: root/graphics/fraqtive
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2018-10-27 17:15:13 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2018-10-27 17:15:13 +0000
commit3920098f6f04fea7b8d76c8f49a251368f09b4c2 (patch)
tree595b10ded02c35ee07d796e91eb7835ac4de67c7 /graphics/fraqtive
parent4322a210bb3615f93c775ec0929be3f041ab7845 (diff)
downloadports-3920098f6f04fea7b8d76c8f49a251368f09b4c2.tar.gz
ports-3920098f6f04fea7b8d76c8f49a251368f09b4c2.zip
graphics/fraqtive:
- Switch to Qt 5 - Add patch to fix build with Qt 5
Notes
Notes: svn path=/head/; revision=483153
Diffstat (limited to 'graphics/fraqtive')
-rw-r--r--graphics/fraqtive/Makefile6
-rw-r--r--graphics/fraqtive/files/patch-qt520
2 files changed, 23 insertions, 3 deletions
diff --git a/graphics/fraqtive/Makefile b/graphics/fraqtive/Makefile
index 75ba27a572b6..5dfa7947af80 100644
--- a/graphics/fraqtive/Makefile
+++ b/graphics/fraqtive/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fraqtive
PORTVERSION= 0.4.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/fraqtive/Fraqtive/Fraqtive%20${PORTVERSION}/
@@ -13,8 +13,8 @@ COMMENT= Draws Mandelbrot and Julia fractals
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake qt:4 tar:bzip2
-USE_QT= corelib gui opengl xml uic_build moc_build rcc_build
+USES= qmake qt:5 tar:bzip2
+USE_QT= core gui opengl widgets xml buildtools_build
USE_GL= gl glu
OPTIONS_DEFINE= SSE2
diff --git a/graphics/fraqtive/files/patch-qt5 b/graphics/fraqtive/files/patch-qt5
new file mode 100644
index 000000000000..63e44d6d504a
--- /dev/null
+++ b/graphics/fraqtive/files/patch-qt5
@@ -0,0 +1,20 @@
+--- src/configurationdata.cpp.orig 2015-01-24 14:43:13 UTC
++++ src/configurationdata.cpp
+@@ -25,6 +25,7 @@
+ #include <shlobj.h>
+ #endif
+
++#include <QDataStream>
+ #include <QDir>
+ #include <cstdlib>
+
+--- src/fractalgenerator.h.orig 2012-12-03 22:37:51 UTC
++++ src/fractalgenerator.h
+@@ -21,6 +21,7 @@
+
+ #include <QEvent>
+ #include <QMutex>
++#include <QObject>
+ #include <QWaitCondition>
+
+ #include "abstractjobprovider.h"