aboutsummaryrefslogtreecommitdiff
path: root/graphics/fraqtive
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/fraqtive')
-rw-r--r--graphics/fraqtive/Makefile6
-rw-r--r--graphics/fraqtive/files/patch-qt520
2 files changed, 23 insertions, 3 deletions
diff --git a/graphics/fraqtive/Makefile b/graphics/fraqtive/Makefile
index 75ba27a572b6..5dfa7947af80 100644
--- a/graphics/fraqtive/Makefile
+++ b/graphics/fraqtive/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fraqtive
PORTVERSION= 0.4.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/fraqtive/Fraqtive/Fraqtive%20${PORTVERSION}/
@@ -13,8 +13,8 @@ COMMENT= Draws Mandelbrot and Julia fractals
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake qt:4 tar:bzip2
-USE_QT= corelib gui opengl xml uic_build moc_build rcc_build
+USES= qmake qt:5 tar:bzip2
+USE_QT= core gui opengl widgets xml buildtools_build
USE_GL= gl glu
OPTIONS_DEFINE= SSE2
diff --git a/graphics/fraqtive/files/patch-qt5 b/graphics/fraqtive/files/patch-qt5
new file mode 100644
index 000000000000..63e44d6d504a
--- /dev/null
+++ b/graphics/fraqtive/files/patch-qt5
@@ -0,0 +1,20 @@
+--- src/configurationdata.cpp.orig 2015-01-24 14:43:13 UTC
++++ src/configurationdata.cpp
+@@ -25,6 +25,7 @@
+ #include <shlobj.h>
+ #endif
+
++#include <QDataStream>
+ #include <QDir>
+ #include <cstdlib>
+
+--- src/fractalgenerator.h.orig 2012-12-03 22:37:51 UTC
++++ src/fractalgenerator.h
+@@ -21,6 +21,7 @@
+
+ #include <QEvent>
+ #include <QMutex>
++#include <QObject>
+ #include <QWaitCondition>
+
+ #include "abstractjobprovider.h"