aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeglut
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-02-08 10:32:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-02-08 10:32:52 +0000
commit48bbd15b98e4d84d522f209769bb16d118792467 (patch)
tree5934e048384cebe7bed6ba19f978b93db64d169c /graphics/freeglut
parent6b5110586c5f0db1aaf88f4df89c1c9d2fbe1443 (diff)
downloadports-48bbd15b98e4d84d522f209769bb16d118792467.tar.gz
ports-48bbd15b98e4d84d522f209769bb16d118792467.zip
- Update to 2.8.0
Changes: * There are now callbacks to support multitouch capability. * Solaris and OSX support have improved. * Fullscreen mode and Game mode behave better. * Addition of Visual Studio 2010 projects & solutions. * Many bugs have been fixed. PR: 163829 Submitted by: Pietro Cerutti <gahr@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=290715
Diffstat (limited to 'graphics/freeglut')
-rw-r--r--graphics/freeglut/Makefile23
-rw-r--r--graphics/freeglut/distinfo4
-rw-r--r--graphics/freeglut/files/extra-patch-src__freeglut_joystick.c34
-rw-r--r--graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c18
-rw-r--r--graphics/freeglut/files/patch-src_freeglut_joystick.c30
5 files changed, 57 insertions, 52 deletions
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index cd16a042dcbf..87e744925033 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -7,23 +7,25 @@
#
PORTNAME= freeglut
-PORTVERSION= 2.6.0
+PORTVERSION= 2.8.0
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}/
+MASTER_SITES= SF
MAINTAINER= graudeejs@gmail.com
COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
+LICENSE= MIT
+
CONFLICTS= libglut-[0-9].*
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_XORG= ice xi
+USE_XORG= ice xi xxf86vm xrandr
USE_GL= glu
CONFIGURE_ARGS= --disable-warnings
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lusbhid
+LDFLAGS+= -L${LOCALBASE}/lib -lusbhid
USE_LDCONFIG= yes
DOCS= download.html freeglut.html freeglut_logo.png \
@@ -31,12 +33,6 @@ DOCS= download.html freeglut.html freeglut_logo.png \
progress.html structure.html
BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src__freeglut_joystick.c
-.endif
-
pre-configure:
.for fract in Fractals/fractals.c Fractals_random/fractals_random.c
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
@@ -63,10 +59,5 @@ post-install:
.endfor
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
-.if ${OSVERSION} >= 800000
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/freeglut/distinfo b/graphics/freeglut/distinfo
index acaa7bbc2661..81ae29d16744 100644
--- a/graphics/freeglut/distinfo
+++ b/graphics/freeglut/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freeglut-2.6.0.tar.gz) = 615b41edc96c405ee6bb7e9a2942642140c3e57c1dd8c68e968a17ddfb59e98f
-SIZE (freeglut-2.6.0.tar.gz) = 1124186
+SHA256 (freeglut-2.8.0.tar.gz) = 197293ff886abe613bc9eb4a762d9161b0c9e64b3e8e613ed7c5e353974fba05
+SIZE (freeglut-2.8.0.tar.gz) = 979459
diff --git a/graphics/freeglut/files/extra-patch-src__freeglut_joystick.c b/graphics/freeglut/files/extra-patch-src__freeglut_joystick.c
deleted file mode 100644
index fa71983cca40..000000000000
--- a/graphics/freeglut/files/extra-patch-src__freeglut_joystick.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- ./src/freeglut_joystick.c.orig 2009-11-14 06:31:39.000000000 +0200
-+++ ./src/freeglut_joystick.c 2010-05-31 21:27:13.362358514 +0300
-@@ -79,11 +79,13 @@
- # include <errno.h>
- # endif
- # if defined(__FreeBSD__) || defined(__NetBSD__)
-+# include <osreldate.h>
- /* XXX The below hack is done until freeglut's autoconf is updated. */
- # define HAVE_USB_JS 1
-
- # if defined(__FreeBSD__)
- # include <sys/joystick.h>
-+# include <dev/usb/usb_ioctl.h>
- # else
- /*
- * XXX NetBSD/amd64 systems may find that they have to steal the
-@@ -200,7 +202,7 @@
- */
- static char *fghJoystickWalkUSBdev(int f, char *dev, char *out, int outlen)
- {
-- struct usb_device_info di;
-+/* struct usb_device_info di;
- int i, a;
- char *cp;
-
-@@ -221,6 +223,7 @@
- return out;
- }
- }
-+ */
- return NULL;
- }
-
-
diff --git a/graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c b/graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c
new file mode 100644
index 000000000000..8f12afa8b524
--- /dev/null
+++ b/graphics/freeglut/files/patch-progs-demos-smooth_opengl3_smooth_opengl3.c
@@ -0,0 +1,18 @@
+--- progs/demos/smooth_opengl3/smooth_opengl3.c.orig 2012-01-04 14:38:43.000000000 +0100
++++ progs/demos/smooth_opengl3/smooth_opengl3.c 2012-01-04 14:39:10.000000000 +0100
+@@ -98,6 +98,7 @@
+ #define APIENTRY
+ #endif
+
++#ifndef GL_VERSION_1_5
+ typedef void (APIENTRY *PFNGLGENBUFFERSPROC) (GLsizei n, GLuint *buffers);
+ typedef void (APIENTRY *PFNGLBINDBUFFERPROC) (GLenum target, GLuint buffer);
+ typedef void (APIENTRY *PFNGLBUFFERDATAPROC) (GLenum target, ourGLsizeiptr size, const GLvoid *data, GLenum usage);
+@@ -117,6 +118,7 @@
+ typedef void (APIENTRY *PFNGLENABLEVERTEXATTRIBARRAYPROC) (GLuint index);
+ typedef GLint (APIENTRY *PFNGLGETUNIFORMLOCATIONPROC) (GLuint program, const ourGLchar *name);
+ typedef void (APIENTRY *PFNGLUNIFORMMATRIX4FVPROC) (GLint location, GLsizei count, GLboolean transpose, const GLfloat *value);
++#endif
+
+ PFNGLGENBUFFERSPROC gl_GenBuffers;
+ PFNGLBINDBUFFERPROC gl_BindBuffer;
diff --git a/graphics/freeglut/files/patch-src_freeglut_joystick.c b/graphics/freeglut/files/patch-src_freeglut_joystick.c
new file mode 100644
index 000000000000..1301a96ed09e
--- /dev/null
+++ b/graphics/freeglut/files/patch-src_freeglut_joystick.c
@@ -0,0 +1,30 @@
+--- src/freeglut_joystick.c.orig 2011-09-28 03:37:26.000000000 +0200
++++ src/freeglut_joystick.c 2012-01-05 09:51:03.000000000 +0100
+@@ -152,7 +152,10 @@
+ # include <libusbhid.h>
+ # endif
+ # endif
+-# include <legacy/dev/usb/usb.h>
++# include <dev/usb/usb.h>
++# if __FreeBSD_version >= 800061
++# include <dev/usb/usb_ioctl.h>
++# endif
+ # include <dev/usb/usbhid.h>
+
+ /* Compatibility with older usb.h revisions */
+@@ -199,6 +202,7 @@
+ */
+ static char *fghJoystickWalkUSBdev(int f, char *dev, char *out, int outlen)
+ {
++#if __FreeBSD_version < 800061
+ struct usb_device_info di;
+ int i, a;
+ char *cp;
+@@ -220,6 +224,7 @@
+ return out;
+ }
+ }
++#endif
+ return NULL;
+ }
+