aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimageview
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /graphics/gimageview
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=357486
Diffstat (limited to 'graphics/gimageview')
-rw-r--r--graphics/gimageview/Makefile28
-rw-r--r--graphics/gimageview/files/patch-ltmain.sh25
-rw-r--r--graphics/gimageview/pkg-plist4
3 files changed, 8 insertions, 49 deletions
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index d2212e416a6b..17be5d28be2a 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gimageview
PORTVERSION= 0.2.27
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= graphics
MASTER_SITES= SF/gtkmmviewer/${PORTNAME}/${PORTVERSION}
@@ -13,15 +13,13 @@ COMMENT= Yet another GTK+ based image viewer
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng15.so:${PORTSDIR}/graphics/png
-USES= gmake pkgconfig
+USES= gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_XORG= xinerama ice
CONFIGURE_ARGS= --with-gtk2
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CFLAGS+= -DUSE_GTK2
CPPFLAGS+= -I${LOCALBASE}/include
-MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= SPLASH NLS LIBMNG LIBWMF LIBRSVG2 LIBEXIF MPLAYER LIBXINE IMLIB
@@ -56,24 +54,12 @@ MPLAYER_CONFIGURE_ENABLE=mplayer
MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
LIBXINE_CONFIGURE_WITH= xine
-LIBXINE_LIB_DEPENDS= xine:${PORTSDIR}/multimedia/libxine
-
-.include <bsd.port.options.mk>
+LIBXINE_LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
post-patch:
- @${REINPLACE_CMD} -e 's/DATADIRNAME=lib/DATADIRNAME=share/g' \
- -e 's|echo aout|echo elf|' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/gnome/apps/|/apps/|' \
- ${WRKSRC}/gimageview.spec \
+ @${REINPLACE_CMD} '/^desktopdir =/s|=.*|= ${DESKTOPDIR}|' \
${WRKSRC}/etc/Makefile.in
- @${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} \
- 's|= $$(DESTDIR)|= |' {} \;
-
-post-configure:
-.if ${PORT_OPTIONS:MIMLIB}
- @${FIND} ${WRKSRC} -name 'Makefile' | ${XARGS} ${REINPLACE_CMD} -Ee \
- 's/^(GDK_IMLIB_(CFLAGS|LIBS) =).*$$/$${1}/'
-.endif
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|= $$(DESTDIR)|= |' -e '/^CPPFLAGS =/s/\\/@CPPFLAGS@ \\/'
.include <bsd.port.mk>
diff --git a/graphics/gimageview/files/patch-ltmain.sh b/graphics/gimageview/files/patch-ltmain.sh
deleted file mode 100644
index 8afad632c287..000000000000
--- a/graphics/gimageview/files/patch-ltmain.sh
+++ /dev/null
@@ -1,25 +0,0 @@
---- ltmain.sh.orig Sat Nov 17 07:22:26 2001
-+++ ltmain.sh Wed Feb 20 16:21:57 2002
-@@ -2690,6 +2690,9 @@
- # Absolute path.
- rpath="$rpath$dir:"
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Relative path: add a thisdir entry.
- rpath="$rpath\$thisdir/$dir:"
-@@ -3360,10 +3363,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/graphics/gimageview/pkg-plist b/graphics/gimageview/pkg-plist
index a27cf3a8d7ec..d1fa442abeb7 100644
--- a/graphics/gimageview/pkg-plist
+++ b/graphics/gimageview/pkg-plist
@@ -32,7 +32,7 @@ lib/gimageview/thumbnail/libgimv_nautilus_thumb.so
lib/gimageview/thumbnail/libgimv_thumb.so
lib/gimageview/thumbnail/libgimv_xvpics_thumb.so
lib/gimageview/thumbnail_view/libgimv_thumbview_detail.so
-share/apps/Graphics/gimageview.desktop
+share/applications/gimageview.desktop
share/doc/gimageview/html/ja/01.html
share/doc/gimageview/html/ja/02.html
share/doc/gimageview/html/ja/03.html
@@ -136,5 +136,3 @@ share/pixmaps/gimv.png
@dirrm share/gimageview/pixmaps/default
@dirrm share/gimageview/pixmaps
@dirrm share/gimageview
-@dirrmtry share/apps/Graphics
-@dirrmtry share/apps