aboutsummaryrefslogtreecommitdiff
path: root/graphics/libjpeg-turbo/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2010-04-26 19:27:02 +0000
committerRene Ladan <rene@FreeBSD.org>2010-04-26 19:27:02 +0000
commit4fb33e994d6065a9b0dda988f1e5085ffa7a9d89 (patch)
tree42b1908d07e0e815755ab4b18678a6acd40edc52 /graphics/libjpeg-turbo/Makefile
parent764f079f6025c79d193e7479821c53c34e1ce325 (diff)
Notes
Diffstat (limited to 'graphics/libjpeg-turbo/Makefile')
-rw-r--r--graphics/libjpeg-turbo/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
new file mode 100644
index 000000000000..e9aeda9a2c5c
--- /dev/null
+++ b/graphics/libjpeg-turbo/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: libjpeg-turbo
+# Date created: 2010-04-09
+# Date modified: 2010-04-12
+# Whom: Denis Podolskiy bytestore@yandex.ru (based on D. R. Commander)
+#
+# $FreeBSD$
+#
+
+PORTNAME= libjpeg-turbo
+PORTVERSION= 0.0.92
+CATEGORIES= graphics
+MASTER_SITES= http://openmoko.spb.ru/repository/ \
+ http://mesh.dl.sourceforge.net/project/libjpeg-turbo/${PORTVERSION}/ \
+ ${MASTER_SITE_XCONTRIB}
+
+MAINTAINER= bytestore@yandex.ru
+COMMENT= Uses MMX, SSE, and SSE2 to accelerate baseline JPEG (de)compression
+
+ONLY_FOR_ARCH= amd64 i386
+USE_AUTOTOOLS= autoconf:262 automake:19 libtool:22
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+BUILD_DEPENDS+= ${LOCALBASE}/bin/nasm:${PORTSDIR}/devel/nasm:install
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+CONFIGURE_ARGS= --host x86_64-unknown-freebsd
+.elif ${ARCH} == i386
+CONFIGURE_ARGS= --host i386-unknown-freebsd
+.endif
+
+pre-configure:
+ @${ECHO_CMD} configure jpeg-turbo library
+ @cd ${WRKDIR}/libjpeg-turbo-${PORTVERSION} && ${AUTORECONF} -fiv && ${LIBTOOLIZE} --force
+
+.include <bsd.port.post.mk>