aboutsummaryrefslogtreecommitdiff
path: root/graphics/linux-c7-sdl_ttf
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
commit1675ff649cded4c85d65feb0f4c5cc87010242eb (patch)
tree3e3556f1e26a35be0250e7f749680b9fc30e9c6b /graphics/linux-c7-sdl_ttf
parent4fd1b570a8aec1244c7b8469c29c309a96a46804 (diff)
downloadports-1675ff649cded4c85d65feb0f4c5cc87010242eb.tar.gz
ports-1675ff649cded4c85d65feb0f4c5cc87010242eb.zip
Add Linux CentOS 7 infrastructure ports.
Mk/Uses/linux.mk changes: - Add support for architecture neutral (noarch) distfiles. - Add support for 64-bit only ports: set IGNORE on i386 and don't install 32-bit compat libraries on amd64. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Differential Revision: https://reviews.freebsd.org/D7886
Notes
Notes: svn path=/head/; revision=424259
Diffstat (limited to 'graphics/linux-c7-sdl_ttf')
-rw-r--r--graphics/linux-c7-sdl_ttf/Makefile28
-rw-r--r--graphics/linux-c7-sdl_ttf/distinfo.x86_645
-rw-r--r--graphics/linux-c7-sdl_ttf/pkg-plist.x86_642
3 files changed, 35 insertions, 0 deletions
diff --git a/graphics/linux-c7-sdl_ttf/Makefile b/graphics/linux-c7-sdl_ttf/Makefile
new file mode 100644
index 000000000000..243604ba2e81
--- /dev/null
+++ b/graphics/linux-c7-sdl_ttf/Makefile
@@ -0,0 +1,28 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= sdl_ttf
+PORTVERSION= 2.0.11
+CATEGORIES= graphics linux
+MASTER_SITES= EPEL7/s
+DISTNAME= ${LINUX_NAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Simple library to load True Type Fonts as SDL interfaces (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-f10-${PORTNAME}-[0-9]* linux-c6-${PORTNAME}-[0-9]*
+
+LINUX_NAME= SDL_ttf
+ONLY_FOR_ARCHS= amd64
+RPMVERSION= 6.el7
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX= jpeg png sdl12 tiff
+USE_LINUX_RPM= yes
+
+DOCSDIR= ${PREFIX}/usr/share/doc/${LINUX_NAME}-${PORTVERSION}
+PORTDOCS= CHANGES COPYING README
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-c7-sdl_ttf/distinfo.x86_64 b/graphics/linux-c7-sdl_ttf/distinfo.x86_64
new file mode 100644
index 000000000000..b34ea92ef059
--- /dev/null
+++ b/graphics/linux-c7-sdl_ttf/distinfo.x86_64
@@ -0,0 +1,5 @@
+TIMESTAMP = 1474466841
+SHA256 (rpm/centos/7.2.1511/x86_64/SDL_ttf-2.0.11-6.el7.x86_64.rpm) = e0984b62e98cdbe3607ad3183b3d9cd8796c24e400f5b03ad834402938d60446
+SIZE (rpm/centos/7.2.1511/x86_64/SDL_ttf-2.0.11-6.el7.x86_64.rpm) = 23224
+SHA256 (rpm/centos/7.2.1511/x86_64/SDL_ttf-2.0.11-6.el7.src.rpm) = dd3c0a301a6a9d17afc0c9603b389baad946bf04dd838811cb813b7f9b2431d3
+SIZE (rpm/centos/7.2.1511/x86_64/SDL_ttf-2.0.11-6.el7.src.rpm) = 4058840
diff --git a/graphics/linux-c7-sdl_ttf/pkg-plist.x86_64 b/graphics/linux-c7-sdl_ttf/pkg-plist.x86_64
new file mode 100644
index 000000000000..d2cca0ecd979
--- /dev/null
+++ b/graphics/linux-c7-sdl_ttf/pkg-plist.x86_64
@@ -0,0 +1,2 @@
+usr/lib64/libSDL_ttf-2.0.so.0
+usr/lib64/libSDL_ttf-2.0.so.0.10.1