aboutsummaryrefslogtreecommitdiff
path: root/graphics/mandelbulber
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-12-14 14:30:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-12-14 14:30:28 +0000
commit193957a077a26ac8a2adcb96fa573450f0745613 (patch)
tree238b4ee7f9e853adb6fef13637e772c5d8881267 /graphics/mandelbulber
parentc982c3c2464e4c95f96dd3d48ff92ca780dd2785 (diff)
downloadports-193957a077a26ac8a2adcb96fa573450f0745613.tar.gz
ports-193957a077a26ac8a2adcb96fa573450f0745613.zip
Mandelbulber is an experimental application that helps to make
rendering 3D Mandelbrot fractals much more accessible. A few of the supported 3D fractals: Mandelbulb, Mandelbox, BulbBox, JuliaBulb, Menger Sponge, Quaternion, Trigonometric, Hypercomplex, and Iterated Function Systems (IFS). All of these can be combined into infinite variations with the ability to hybridize different formulas together. WWW: http://www.mandelbulber.com/
Notes
Notes: svn path=/head/; revision=308905
Diffstat (limited to 'graphics/mandelbulber')
-rw-r--r--graphics/mandelbulber/Makefile50
-rw-r--r--graphics/mandelbulber/distinfo2
-rw-r--r--graphics/mandelbulber/files/patch-makefiles-makefile11
-rw-r--r--graphics/mandelbulber/files/patch-makefiles-src-subdir.mk11
-rw-r--r--graphics/mandelbulber/files/patch-src-netrender.cpp10
-rw-r--r--graphics/mandelbulber/files/patch-src-netrender.hpp10
-rw-r--r--graphics/mandelbulber/pkg-descr8
7 files changed, 102 insertions, 0 deletions
diff --git a/graphics/mandelbulber/Makefile b/graphics/mandelbulber/Makefile
new file mode 100644
index 000000000000..1e4947849e90
--- /dev/null
+++ b/graphics/mandelbulber/Makefile
@@ -0,0 +1,50 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mandelbulber
+DISTVERSION= 1.13-1
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}
+DISTNAME= ${PORTNAME}${DISTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= 3D Mandelbrot fractal renderer
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GMAKE= yes
+USE_GNOME= glib20 gtk20
+BUILD_WRKSRC= ${WRKSRC}/makefiles
+MAKEFILE= makefile
+CXXFLAGS+= -DSHARED_DIR=\\\"${DATADIR}\\\"
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/${PORTNAME} share/applications/${PORTNAME}.desktop
+PLIST_DIRSTRY= share/applications
+
+PORTDOCS= README NEWS
+PORTDATA= *
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/mandelbulber|${DATADIR}|' \
+ ${WRKSRC}/${PORTNAME}.desktop
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${PREFIX}/share/applications
+.if !defined(NOPORTDATA)
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/usr/share && ${COPYTREE_SHARE} '*' ${DATADIR}/
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/mandelbulber/distinfo b/graphics/mandelbulber/distinfo
new file mode 100644
index 000000000000..63c5249ff574
--- /dev/null
+++ b/graphics/mandelbulber/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mandelbulber1.13-1.tar.gz) = 97edc8b08fc229e68ea58fd835581274b783ff4211b4db87c81efbdef799bd92
+SIZE (mandelbulber1.13-1.tar.gz) = 1200010
diff --git a/graphics/mandelbulber/files/patch-makefiles-makefile b/graphics/mandelbulber/files/patch-makefiles-makefile
new file mode 100644
index 000000000000..4afc83c42f31
--- /dev/null
+++ b/graphics/mandelbulber/files/patch-makefiles-makefile
@@ -0,0 +1,11 @@
+--- makefiles/makefile.orig 2012-12-02 20:22:54.000000000 +0400
++++ makefiles/makefile 2012-12-13 01:08:10.313933225 +0400
+@@ -44,7 +44,7 @@
+ mandelbulber: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C++ Linker'
+- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) -o"mandelbulber" -L$(LOCALBASE)/lib $(OBJS) $(USER_OBJS) $(LIBS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
diff --git a/graphics/mandelbulber/files/patch-makefiles-src-subdir.mk b/graphics/mandelbulber/files/patch-makefiles-src-subdir.mk
new file mode 100644
index 000000000000..93e30c4ff8a6
--- /dev/null
+++ b/graphics/mandelbulber/files/patch-makefiles-src-subdir.mk
@@ -0,0 +1,11 @@
+--- makefiles/src/subdir.mk.orig 2012-12-02 20:22:54.000000000 +0400
++++ makefiles/src/subdir.mk 2012-12-13 01:07:24.472933242 +0400
+@@ -71,7 +71,7 @@
+ src/%.o: ../src/%.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
++ $(CXX) $(CXXFLAGS) -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+
diff --git a/graphics/mandelbulber/files/patch-src-netrender.cpp b/graphics/mandelbulber/files/patch-src-netrender.cpp
new file mode 100644
index 000000000000..bce85f52b099
--- /dev/null
+++ b/graphics/mandelbulber/files/patch-src-netrender.cpp
@@ -0,0 +1,10 @@
+--- src/netrender.cpp.orig 2012-12-02 20:22:54.000000000 +0400
++++ src/netrender.cpp 2012-12-13 01:06:24.748933214 +0400
+@@ -7,6 +7,7 @@
+
+ #include "netrender.hpp"
+ #include <stdio.h>
++#include <netinet/in.h>
+ #ifndef WIN32
+ #include <arpa/inet.h>
+ #endif
diff --git a/graphics/mandelbulber/files/patch-src-netrender.hpp b/graphics/mandelbulber/files/patch-src-netrender.hpp
new file mode 100644
index 000000000000..0e9e02391012
--- /dev/null
+++ b/graphics/mandelbulber/files/patch-src-netrender.hpp
@@ -0,0 +1,10 @@
+--- src/netrender.hpp.orig 2012-12-02 20:22:54.000000000 +0400
++++ src/netrender.hpp 2012-12-13 01:05:50.537932343 +0400
+@@ -19,6 +19,7 @@
+ #include <winsock2.h>
+ #define INET6_ADDRSTRLEN 46
+ #else
++ #include <arpa/inet.h>
+ #include <sys/socket.h>
+ #include <netdb.h>
+ #endif
diff --git a/graphics/mandelbulber/pkg-descr b/graphics/mandelbulber/pkg-descr
new file mode 100644
index 000000000000..e044c022ad43
--- /dev/null
+++ b/graphics/mandelbulber/pkg-descr
@@ -0,0 +1,8 @@
+Mandelbulber is an experimental application that helps to make
+rendering 3D Mandelbrot fractals much more accessible. A few of the
+supported 3D fractals: Mandelbulb, Mandelbox, BulbBox, JuliaBulb,
+Menger Sponge, Quaternion, Trigonometric, Hypercomplex, and Iterated
+Function Systems (IFS). All of these can be combined into infinite
+variations with the ability to hybridize different formulas together.
+
+WWW: http://www.mandelbulber.com/