aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_gfx
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-13 13:56:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-13 13:56:38 +0000
commit4bccb6d5b219ff36ca0e7691e3a303f49686b764 (patch)
treec0c43bab2332b4a0f76db1e7fb44a98d5e6dc389 /graphics/sdl_gfx
parent716c18c6707498e556e96749e88c3cb01d69b2f2 (diff)
downloadports-4bccb6d5b219ff36ca0e7691e3a303f49686b764.tar.gz
ports-4bccb6d5b219ff36ca0e7691e3a303f49686b764.zip
- Update to 2.0.16
- OPTIONize MMX flag - Pass maintainership to submitter PR: 117612 Submitted by: Marcus von Appen <mva@sysfault.org>
Notes
Notes: svn path=/head/; revision=208947
Diffstat (limited to 'graphics/sdl_gfx')
-rw-r--r--graphics/sdl_gfx/Makefile13
-rw-r--r--graphics/sdl_gfx/distinfo6
-rw-r--r--graphics/sdl_gfx/pkg-plist3
3 files changed, 13 insertions, 9 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index b19d4519583d..9081decbaa94 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -7,15 +7,14 @@
#
PORTNAME= sdl_gfx
-PORTVERSION= 2.0.13
-PORTREVISION= 3
+PORTVERSION= 2.0.16
CATEGORIES= graphics
MASTER_SITES= http://www.ferzkopp.net/Software/%SUBDIR%/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
MASTER_SITE_SUBDIR= SDL_gfx-${PORTVERSION:R}
DISTNAME= SDL_gfx-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mva@sysfault.org
COMMENT= SDL graphics drawing primitives and other support functions
USE_AUTOTOOLS= libtool:15
@@ -23,16 +22,20 @@ USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --includedir=${PREFIX}/include \
- --disable-mmx
+CONFIGURE_ARGS= --includedir=${PREFIX}/include
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
USE_LDCONFIG= yes
+OPTIONS= MMX "Enable MMX instruction set (i386 only)" Off
+
.include <bsd.port.pre.mk>
.if defined(WITH_MMX) && (${ARCH} == "i386")
+CONFIGURE_ARGS+=--enable-mmx
CFLAGS+= -DUSE_MMX
+.else
+CONFIGURE_ARGS=--disable-mmx
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/sdl_gfx/distinfo b/graphics/sdl_gfx/distinfo
index a8958264e826..182cc4db685a 100644
--- a/graphics/sdl_gfx/distinfo
+++ b/graphics/sdl_gfx/distinfo
@@ -1,3 +1,3 @@
-MD5 (SDL_gfx-2.0.13.tar.gz) = b1ce778232db0b1979695f0a5a945a13
-SHA256 (SDL_gfx-2.0.13.tar.gz) = d350706545894d1a60c6fa9109349c420ba86bb7243c770cf1602ccc820661d6
-SIZE (SDL_gfx-2.0.13.tar.gz) = 598297
+MD5 (SDL_gfx-2.0.16.tar.gz) = 22dc2d9d916197829f9342c490d2d02b
+SHA256 (SDL_gfx-2.0.16.tar.gz) = 1ac780303b76bc830b837e6030de60943df0c28d7b9dab3a7229427bb6f4c2ea
+SIZE (SDL_gfx-2.0.16.tar.gz) = 830086
diff --git a/graphics/sdl_gfx/pkg-plist b/graphics/sdl_gfx/pkg-plist
index 3d7963133e8d..85e0d9cace89 100644
--- a/graphics/sdl_gfx/pkg-plist
+++ b/graphics/sdl_gfx/pkg-plist
@@ -1,4 +1,5 @@
include/SDL/SDL_framerate.h
+include/SDL/SDL_gfxBlitFunc.h
include/SDL/SDL_gfxPrimitives.h
include/SDL/SDL_gfxPrimitives_font.h
include/SDL/SDL_imageFilter.h
@@ -6,5 +7,5 @@ include/SDL/SDL_rotozoom.h
lib/libSDL_gfx.a
lib/libSDL_gfx.la
lib/libSDL_gfx.so
-lib/libSDL_gfx.so.13
+lib/libSDL_gfx.so.0
@dirrmtry include/SDL