aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-08-10 08:55:08 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-08-10 08:55:08 +0000
commit0ed44f8feb77fe93ca1b69787d23b072ad29468b (patch)
tree7dba53066d09a8c2cd4023bc7e2ec06918f0f0d3 /graphics
parent54df1957a421ea7c8241d0299e2deb666f031d26 (diff)
downloadports-0ed44f8feb77fe93ca1b69787d23b072ad29468b.tar.gz
ports-0ed44f8feb77fe93ca1b69787d23b072ad29468b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender/Makefile3
-rw-r--r--graphics/py-PyX/Makefile6
-rw-r--r--graphics/py-PyX12/Makefile6
3 files changed, 7 insertions, 8 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index c6e7698b031c..994b80f6d801 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
USE_XORG= x11 xext xmu
USE_GL= glew
-USES= cmake:outsource compiler:features shebangfix
-USE_PYTHON= 3.4
+USES= cmake:outsource compiler:features python:3.4 shebangfix
CMAKE_ARGS+= -DWITH_PYTHON_INSTALL:BOOL=OFF \
-DWITH_PYTHON_INSTALL_NUMPY:BOOL=OFF
diff --git a/graphics/py-PyX/Makefile b/graphics/py-PyX/Makefile
index 6f71b2f6640f..04ca0bc9e790 100644
--- a/graphics/py-PyX/Makefile
+++ b/graphics/py-PyX/Makefile
@@ -12,11 +12,11 @@ COMMENT= Python package for creating encapsulated PostScript figures
LICENSE= GPLv2
-USE_PYTHON= 3
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:3
USE_TEX= latex:build
+PYTHON_FEATURES= autoplist distutils
+
OPTIONS_DEFINE= T1CODE KPATHSEA
OPTIONS_DEFAULT= T1CODE KPATHSEA
T1CODE_DESC= Fast t1 font encoding/decoding
diff --git a/graphics/py-PyX12/Makefile b/graphics/py-PyX12/Makefile
index 65a607279f13..97e5271f6839 100644
--- a/graphics/py-PyX12/Makefile
+++ b/graphics/py-PyX12/Makefile
@@ -13,11 +13,11 @@ COMMENT= Python package for creating encapsulated PostScript figures
LICENSE= GPLv2
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
USE_TEX= latex:build
+PYTHON_FEATURES= autoplist distutils
+
OPTIONS_DEFINE= T1CODE KPATHSEA
OPTIONS_DEFAULT= T1CODE KPATHSEA
T1CODE_DESC= Fast t1 font encoding/decoding